Problem with Time Server setting in wnos.ini

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1945
    Avatarsamshem
    Member
    • Total Post: 3
    • Newbie

    I have tried everything, but can not seem to get the Timeserver=X function working properly. I have Timeserver=time.windows.com in my wnos.ini file, and when the S10 is restarted, the Time Server field in the network settings is populated with time.windows.com. The problem however, is that when I review the event log, it does not specify that it is connecting to the sntp server (time.windows.com) and the time is not is not displayed. If I go into the network setup and manually put the address in (assuming it is not what is specified in the wnos.ini file) and restart, it works fine. Any help is appreciated. Below is the time portion of my wnos.ini file.

    Thanks

    # Time Settings
    Timeserver=time.windows.com Timeformat=”12-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT – 05:00′ ManualOverride=yes Daylight=yes Start=030207 End=110107 TimeZoneName=”Eastern Standard Time” DayLightName=”Eastern Daylight Time”

    #15326
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Hi,

    I have just tested with time.windows.com and it is working perfectly for me.
    As you can see in the eventlog I had configured ntp0.pipex.net. After reading the modified wnos.ini it directly changed to time.windows.com and successfully used it.

    24: Looking up IP address from DHCP …
    25: Contacting SNTP [ntp0.pipex.net] …
    26: Contacting File Server …
    27: Accessing system profile …
    28: Contacting SNTP [time.windows.com] …
    29: Checking Software ftp:/wnos/VL10_wnos …
    30: Contacting SNTP [time.windows.com] …

    Cheers
    CG

    #15333
    AvatarSami
    Member
    • Total Post: 6
    • Newbie

    This is Samshem, for some reason I could not reply using that account as the forums were not viewable when logged in, so I created a new account.

    Anyway, is there something else in my WNOS file that may prevent this from working correctly? It is very strange that the Time Server field will be populated correctly, but it basically ignores it when starting up.

    Below is the WNOS I am using.

    Thanks

    # General

    autoload=2
    PnliteServer=

    # Display

    Resolution=1024×768
    DeskColor=”58 110 165″
    Desktop=logo.bmp
    LongApplicationName=Yes
    ScreenSaver=20

    # Network

    SignOn=No
    MaxVNCD=2
    VncPassword=”password”
    VncPrompt=No Accept=

    # Time Settings
    Timeserver=time.windows.com Timeformat=”12-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT – 05:00′ ManualOverride=yes Daylight=yes Start=030207 End=110107 TimeZoneName=”Eastern Standard Time” DayLightName=”Eastern Daylight Time”

    # Published Applications

    CONNECT=ICA
    BrowserIP=path
    Application=”Name”
    Description=”Name”
    Icon=default
    AutoConnect=0
    Colors=high
    Fullscreen=yes
    LocalCopy=yes

    CONNECT=ICA
    BrowserIP=path
    Application=”name”
    Description=”name”
    Icon=default
    AutoConnect=0
    Colors=high
    Fullscreen=yes
    HTTPBrowsing=1
    LocalCopy=yes

    #15334
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Two things you should adjust:

    PNliteServer= – here should be a value

    VncPrompt=No Accept= – here also

    Valid parameters could look like

    PNliteServer=mycitrixserver

    VncPrompt=No Accept=5

    CG

    #15341
    AvatarSami
    Member
    • Total Post: 6
    • Newbie

    I removed the PNliteServer= ( do not use it, I put that in there to make sure it was empty on the terminals).

    I removed the = after VNCPrompt=No Accept

    It is now using time-a.nist.gov which is one I manually put into the timeserver field during testing. In the WNOS however, time.windows.com is still listed and populating in the Time Servers field.

    #15342
    AvatarSami
    Member
    • Total Post: 6
    • Newbie

    As an update, I was able to reproduce this in a different way.

    1. S10 points to WNOS 1. WNOS 1 states time.windows.com as time server.
    2. Restart S10, Time Servers field has time.windows.com specified. Event log still uses an older time server (or none at all).
    3. Point S10 to WNOS 2. WNOS 2 states ntp.nasa.com as time server.
    4. Restart S10, Time Servers field has ntp.nasa.com specified. Event shows that time.windows.com is used.

    It seems that the terminal is using the time server from the previous setup only, and not the current wnos it points to. For reference, the S10 is running 5.3.0_09 firmware.

    #15343
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Try to reset your unit to factory default once and let it read the wnos.ini files then again.

    CG

    #15346
    AvatarSami
    Member
    • Total Post: 6
    • Newbie

    @ConfGen wrote:

    Try to reset your unit to factory default once and let it read the wnos.ini files then again.

    CG

    That worked. The problem however is that we have over 800 terminals, some S10s, some 1200le’s (which the same thing happens to), having everyone reset them is not really the best option. Is there a way in the WNOS to force the update?

    #15347
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Add FactoryDefault=1 to your wnos.ini.
    This should reset all units once.

    CG

    #15349
    AvatarSami
    Member
    • Total Post: 6
    • Newbie

    @ConfGen wrote:

    Add FactoryDefault=1 to your wnos.ini.
    This should reset all units once.

    CG

    Great! Thanks very much for the help.

    #15350
    AvatarSami
    Member
    • Total Post: 6
    • Newbie

    @ConfGen wrote:

    Add FactoryDefault=1 to your wnos.ini.
    This should reset all units once.

    CG

    When is it supposed to do it, upon reboot? I added it and restarted, and it didn’t reset.

    #15355
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    AFAIK the units only do that once after a firmware up- or downgrade.
    Contact Wyse to get the latest 5.3. version for your units and do an upgrade.

    CG

    #43363
    Avatardcordina
    Participant
    • Total Post: 1
    • Newbie

    Hi,

    I am having the same issue regarding the dns/wins can’t resolve.

    this is my wnos.ini file

    AutoLoad=1
    TimeServer=Timeserver=time.windows.com TimeFormat=”24-hour format” DateFormat=dd/mm/yyyy
    TimeZone=’GMT + 01:00′ ManualOverride=Yes Daylight=Yes Start=030207 End=110107
    TimeZoneName=”Central” DaylightName=”Central”

    signOn=no
    SessionConfig=all mapdisks=yes
    connect= rdp \
    host=172.22.3.241 \
    Description=”Senior” \
    icon=default \
    resolution=1024×768 \
    domainname=dlsmalta \
    fullscreen=yes \
    autoconnect=no

    signOn=no
    SessionConfig=all mapdisks=yes
    connect= rdp \
    host=172.22.3.242 \
    Description=”Junior” \
    icon=default \
    resolution=1024×768 \
    domainname=dlsmalta \
    fullscreen=yes \
    autoconnect=no

    include=$mac.ini

    #43370
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    TimeServer=Timeserver=time.windows.com

    ???

    Double TimeServer?

    CG

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.