Problem with S90s after upgrading WDM Workgroup to 4.9.1

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #7343
    angelo
    Member
    • Total Post: 5
    • Newbie
    • ★

    Hello all,
    first post here so hello to everyone!!!
    I’m here because we’ve a problem with the latest version of WDM Workgroup and we’re not getting so much help from Wyse… problem is this: we have almost six hundreds of S90s with XPe SP2 and we were manage them using the 4.8.0 version, configured not to upgrade automatically the agents because we want to do that manually.
    After upgraded to 4.9.1, passing by 4.9.0 only to install the latest version, we discovery too late that the option to automatically upgrade the agents was enabled so there was hundreds of scheduled packages in queue… we deleted all of them but now we have many S90 that are continuously showing the update request (I mean the one with ‘now’ and ‘5 minute delay’ buttons) after every reboot.
    Actually the only way to stop them asking to update/reboot is to keep the server down, so we’d like to know what we can do in order to delete any pending request to upgrade… I checked the SQL tables using the MDTools and I haven’t found anything, but I’ve to say I don’t even know what I should search.
    Any ideas?
    Many thanks in advance!
    Best regards

    Angelo

    P.S. sorry for my english…

    #22302
    pufthemajicdragon
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    Hello! 🙂
    Check and see if Automatically Upgrade Older Agents is enabled. You’ll find it under Device Manager preferences in a little box labeled “Auto Agent Upgrade Preferences”.

    FYI 4.9.1 REQUIRES an updated HAgent on client machines, or most of your management features will be unavailable. See Solution 22448: Documentation – Wyse Device Manager 4.9.1 and read the Installation Guide, Chapter 2: Preparing for Installation.

    #22320
    angelo
    Member
    • Total Post: 5
    • Newbie
    • ★

    Hello Pufthemajicdragon,
    thank you for your answer.
    Yes that option was disabled as soon as we discovered that it was enabled by default, so why the clients that have received the input to automatically upgrade the hagent are still trying to do that?
    That stop only if I shutdown the server, so we think that WDM is still trying to send that input even the option id disabled and the scheduled packaged queue is empty: if so, what we have to do to stop that without shutdown the server?

    #22321
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Download WDM SQL Queries Tool from this site and clean the job table.

    CG

    #22332
    angelo
    Member
    • Total Post: 5
    • Newbie
    • ★

    Thanks ConfGen,
    I just got the tool, this morning I’d be able to use it then I’ll let you know the result.
    Many thanks again.
    Best regards

    Angelo

    #22333
    angelo
    Member
    • Total Post: 5
    • Newbie
    • ★

    Ok, I’m feeling like a dumb… if I click on ‘delete pending jobs’ I get the ‘finished – should work’ message but terminals are still in loop.
    If I click any of the ‘none destructive functions’ buttons I’m always getting a ‘no valid server given’, no matter if I use ‘servername’ or ‘servernamerapportdb’.
    First question: I’ve tried both, but I’ve to use the tool in local or from remote?
    Second question: the tool use ‘rapport’ as default user, is that right?
    I even tried to use ‘sa’ but no luck… I’m feeling very dumb… 🙁

    #22342
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Enter the IP address of your WDM server in the field “Server Instance” and click on “Call Servers”.
    It should then find the server.
    After it has found the server, choose RapportDB in the database field.
    Username rapport is fine as long as you haven’t changed it manually during setup.

    CG

    #22343
    angelo
    Member
    • Total Post: 5
    • Newbie
    • ★

    Using the ‘sa’ user (not rapport, I don’t know what’s the initially provided password but even giving his password – standard one – it doesn’t work) I was able to use the non distructive functions and the ‘pending jobs’ queue is empty.
    Nevertheless terminals are still in loop…

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.