Problem pushing a WDM package through the Internet.

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1953
    Avatarrtw68
    Member
    • Total Post: 6
    • Newbie

    Hello,

    I’m hoping what I’m trying to do will work. We have a large number of customers that are using their own LAN connections that aren’t connected to our WDM Workgroup server other than through our firewall (ports 80,20,21) on the internet. What I want to accomplish is simply push out small package updates as needed to the Wyse V90L’s. If an entire image is needed, I will send a USB key using the Wyse USB Imager.

    In my tests, the V90’s do show up in the Device Manager section in Green, but when I try to send a package, it fails with “Unable to connect to the Client. Update Moved to Error.” I tried changing it to a future schedule and rebooting the thin client, but it stills fails.

    Is there another way to push package updates out to recognized thin clients?

    Thanks in advance for any assistance.

    Randy…

    #15353
    Avatarrtw68
    Member
    • Total Post: 6
    • Newbie

    An update. I moved the schedule to five minutes ahead and rebooted the thin client. It then started to do the update. I checked WDM and it came back with another error message:
    [Try 1:FTP Connect Error Server: 172.25.0.20 Return:(null) Line #: 35 Cmd: XC “UpdateVWorkspace*” Z:”]

    I am able to log in to the FTP server (outside the firewall) as anonymous and see the folder and my files inside the folder shown above.

    What would be causing the error above?

    #15361
    ConfGenConfGen
    Keymaster
    • Total Post: 11007
    • Jedi Master
    • ★★★★★★★

    Looks like your script is not correct.
    Try XC “UpdateVWorkspace*” Z:”

    is a variable for the scripts directory inside ftprootrapport

    CG

    #15370
    Avatarrtw68
    Member
    • Total Post: 6
    • Newbie

    Here is the line from that script: XC “*” “Z:” so I know that is correct (and it did work with locally connected V90L’s when testing).

    I did figure out last night that the thin client was trying to connect to FTP using the LAN IP address. What I did was created a sub-domain that is accessible from the internet for the thin client, and modified the host file to point that sub-domain to the local server’s LAN IP address, modified the MASTER repository, then it worked… Once.

    Now I’m back to the original error message. I think I may have gotten lucky the first time with lucky timing and it worked. Now, even if I schedule the jobs in the future and restart the V90L, the jobs fail.

    #15374
    ConfGenConfGen
    Keymaster
    • Total Post: 11007
    • Jedi Master
    • ★★★★★★★

    Check the Preferences – Scheduling of WDM and deactivate the Timeout Bounds.

    CG

    #15388
    Avatarrtw68
    Member
    • Total Post: 6
    • Newbie

    Thank you very much sir! You are a genius! 🙂

    #15390
    ConfGenConfGen
    Keymaster
    • Total Post: 11007
    • Jedi Master
    • ★★★★★★★

    I know but I love to hear it 😀

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.