Powerterm configuration file (pts)

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1469
    Avatarpaschyth
    Member
    • Total Post: 5
    • Newbie

    Hi,

    I set up our V50 by DHCP and wlx.ini

    Here are the lines for the PowerTerm-Connection:
    CONNECT=TEC
    Autoconnect=no
    Reconnect=no
    Description=”wym”
    Localcopy=yes
    filename=”wym”
    filepath=”/wyse/wlx/tec”
    Host=”klewer1″
    terminal=”sco-ansi”
    termname=wansi
    uiconfig=”menu,status,buttons”
    startmenu=1
    desktop=1

    The logfile of the ftp-server shows, that the following files downloaded correct:
    wym.pts, wym.ptc, wym.ptk, wym.ptp

    Additional the terminal tries to download “wym.ptx” and “toolbar.ini”.
    I can’t find informations for this files.

    The emulation starts and connects to our server, but with the wrong Codepage.
    In the wym.pts i have the following lines:
    UPS-Set = ISO-Latin-1
    PC-Code-Page = ISO-Latin-1
    PC-CP-8bit-Controls = Disabled

    But the emulator use “Code-Page-858” and UTF-encodings. I have no idea why?

    If i look in the files, that stored on my wyse, i see, that the “/home/root/qterm/wym/tec.pts” which was created after PowerTerm-Start looks different to that, which i created!?

    I hope someone could help me and sorry for my bad english.

    #13946
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★
    #13947
    Avatarpaschyth
    Member
    • Total Post: 5
    • Newbie

    Thanks for the fast response.

    This is exactly what i did!
    But it looks like that the “wym.pts” would be changed on startup of powerterm after downloading it from the ftp-server. No idea why.

    Perhaps powerterm needs the ptx-file, but no idea, for what the ptx-file is???

    #13952
    Avatarpaschyth
    Member
    • Total Post: 5
    • Newbie

    It was a long way to go. 😉

    I find out, that “/etc/addons.d/TEC/launch” retrieves the pst-file.
    And after retrieving it changes some lines. If the keyboard-layout is “de”, “fr” or “es” than UPS-Set will be changed to “Code-Page-858” and “UTF-8” will be changed to “On”.

    If i change this launch-script manualy, so everything works fine (fine for my applications 😉 ).

    So i will try to make a little patch-pak, to change this file automaticaly.

    #13953
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    Good catch. If you make this addon, please forward it as maybe other may use it also.

    BTW, Wyse is going to launch a new Suse based Linux the next weeks.

    CG

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.