PNAgent/PNLite with individual user.ini files

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #41679
    sast0n
    Participant
    • Total Post: 5
    • Newbie

    We have Wyse terminals that connect to PNAgent via the wnos.ini. They boot up to a log in box

    User name
    Password
    Domain

    then launch the users desktop.

    How can I get individual username.ini files to apply in this scenario?

    I have the username.ini file in the path inetpub\ftproot\wyse\wnos\ini path but I cannot see the user settings I want applying.

    I see this statement in the wnos.ini guide but I don’t understand it:
    CAUTION: If both PNAgent/PNLite and a user profile are being used in the
    environment, the username must be defined in the Windows domain to be used, and
    the password used must be the same for both the Windows domain and the user
    profile.

    • This topic was modified 5 years, 10 months ago by sast0n.
    #41682
    ConfGen
    Keymaster
    • Total Post: 11368
    • Jedi Master
    • ★★★★★★★

    What settings do you want to apply via username.ini?

    CG

    #41685
    sast0n
    Participant
    • Total Post: 5
    • Newbie

    Say I want a particular user to be able to see and get into certain system settings after they log on like ‘display’ or ‘peripherals’.

    At the moment, once the user logs on its the same for everyone, even if I put different settings in the user.ini.

    #41686
    ConfGen
    Keymaster
    • Total Post: 11368
    • Jedi Master
    • ★★★★★★★

    Make sure the name of the username.ini is exactly matching the users logon name.
    If my account is called “Confgen”, then my user.ini has to be Confgen.ini.

    CG

    #41687
    ConfGen
    Keymaster
    • Total Post: 11368
    • Jedi Master
    • ★★★★★★★

    Hi,

    I have tested this today and it IS working perfectly fine.
    Here is what I did:
    – entered pnliteserver=server1 in my wnos.ini
    – created a user1.ini in wnos\ini folder
    – added pnliterserver=server2 in the user1.ini
    – started the ThinOS unit and verified that “server1” is used
    – logged in a user1 and verified that “server2” was used.

    Other settings like language, additional RDP session, etc. are also working as expected.

    That was working perfectly fine with several 8.x firmware versions.

    CG

    • This reply was modified 5 years, 10 months ago by ConfGen.
    • This reply was modified 5 years, 10 months ago by ConfGen.
    • This reply was modified 5 years, 10 months ago by ConfGen.
    #41693
    sast0n
    Participant
    • Total Post: 5
    • Newbie

    Thanks for your reply.

    I am still looking at it . Here is what I have found so far, using your example:

    – entered pnliteserver=server1 in my wnos.ini
    – created a user1.ini in wnos\ini folder
    – added pnliterserver=server2 in the user1.ini
    – started the ThinOS unit and verified that “server1″ is used
    – logged in a user1 and verified that “server2″ was used.

    I get the same in respect of the pnliteserver: my user1.ini file was the file from which the pnliteserver came (server2). I also got my other settings in my user1.ini file applied , such as Privilege=High. The only difference is that on my user1.ini file I am NOT doing an autolaunch of the desktop.

    When I go back to using pnliteserver=server1 in the user1.ini file, it just launches the desktop straight away. No way to see the user1.ini settings unless you go in as admin mode.
    After the auto launch, you do NOT get any of your user1.ini settings. ???

    #41695
    sast0n
    Participant
    • Total Post: 5
    • Newbie

    I managed to get out of the full desktop and check the settings and yes, it is applying the correct user.ini, so question answered. Thanks.

    I forgot you could get in to the terminal settings by pressing the right keystrokes.

    I have still got a strange issue where in my globlal.ini on the terminal it has autoconnectlist=”my published desktop” and in the user.ini it does not have that autoconnect entry. When you log in, it still autoconnects to the published desktop despite the fact that there is no autoconnect written in the user.ini file. It is almost as if the global.ini on the Wyse terminal is overriding the settings in the user.ini just for that particularl autoconnect setting.

    • This reply was modified 5 years, 10 months ago by sast0n.
    #41697
    ConfGen
    Keymaster
    • Total Post: 11368
    • Jedi Master
    • ★★★★★★★

    Can you try and add pnliteserver=server2 Autoconnectlist=”” to your user.ini?

    CG

    #42072
    sast0n
    Participant
    • Total Post: 5
    • Newbie

    Yes, that’s has fixed it. Many thanks.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.