Password reset……………….

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7108
    AvatarShaunRitchie
    Member
    • Total Post: 3
    • Newbie

    I’ve been trying to get password reset features for WTOS working for about 6 months now.

    It’s very very badly documented.

    Anyway, I am nearly there but I get two password reset dialog boxes that appear. The first one does not work. Whatever password I enter I always get the message SMB: Invalid new password, please retry.

    If I hit escape on this I get another password dialog box which I am able to use to change my password.

    Does anyone know why the first one doesn’t work or how I can get rid of it?

    #21762
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    What have done so far?
    What backend?
    What firmware?

    CG

    #21770
    AvatarShaunRitchie
    Member
    • Total Post: 3
    • Newbie

    @ConfGen wrote:

    What have done so far?
    What backend?
    What firmware?

    CG

    Well, it took me months to find out that NTLM needs to be enabled in the ini file for the password reset function to work.

    Have all the correct settings configured on the Web Interface. Like I said, this actually works but only if you press escape on the first dialog box and then change your password on the second dialog box. We can’t release this to users, imagine how confusing it will be.

    We have XenDesktop 5.5 at the backend.

    Firmware is 7.1_033

    #21771
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    You do NOT need NTLM to be able to change a password. All you need is to configure the PNAgent site to allow password changes like explained in my doc posted on this website in Products-Wyse ThinOS.

    CG

    #21818
    AvatarAmerist
    Participant
    • Total Post: 61
    • Back Stage Pass
    • ★★★★

    I had similar issues when I was trying to get this to work. I followed the guide offered by ConfGen but I think because our Citrix environment is an oder one (PS 4.5 on Server 2003 domain) we need to use these two lines in our WNOS.INI. For us it did not work without Signon=ntlm. I tried all other valid optons for this value : (yes, no, 0, 1) and nothing else worked for me. I highly recommend downloading the Reference Guide for Wyse ThinOS INI Files which is located on Wyse.com

    Signon=ntlm
    PnliteServer=xxx.xxx.xxx.xxx

    where xxx.xxx.xxx.xxx is the IP address of your web interface or “server hosting published resources” as described by XenApp Online Plugin.

    When I was having this problem I was testing using a $MAC.ini file and a single device so I wouldn’t disrupt the rest of the world with my experimentation. My pitfall was that I was not putting

    Exit=All

    At the end of my $MAC.ini file and the other problem I ran into was I had another location in my $MAC.ini where I had specified

    Signon=1

    which effectively cancelled out the previous Signon=NTLM.

    #21819
    AvatarShaunRitchie
    Member
    • Total Post: 3
    • Newbie

    This is fixed now.

    We were working on a project that required some new web interface servers.

    Anyway, it now works with the new WI servers. Exactly the same settings as the old ones (also exactly the same version of Web Interface) so really no idea what was causing the issue.

    Anyway, spent a long long time trying to get this working.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.