Notification Area as thinuser

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6867
    Lavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    I’ve tried every combination of commands in the ini I can think of, but in the newest firmware 11.1.031 I just can’t get the notification area, which contains the system information icon, to appear when logged in as thinuser.

    Does anyone know what I might be missing?

    Thanks.

    #21182
    Lavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    I know There hasn’t been many views for this, but i was able to come up with a package that performed the task I required. inside of a shell script that runs at login, run these commands:

    echo “before command”
    su – thinuser -f -c “gconftool-2 –set /apps/panel/global/locked_down –type bool true”
    su – thinuser -f -c “gconftool-2 –type list –set /apps/panel/general/applet_id_list –list-type string [,notification_area_screen0,window_list_screen0,notification_area_screen0,clock_screen0,mixer_screen0,main_menu_screen0]”
    su – thinuser -f -c “killall gconfd-2”
    su – thinuser -f -c “gconfd-2”
    su – thinuser -f -c “killall gnome-panel”

    works great on 11.1.031

    #21183
    Lavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    as an aside, because I didn’t notice until I poseted. the first command locks the control panel from thinuser being able to right click on the desktop and being able to add whatever they want to it. essentially giving admin access…

    #22883
    ericgst
    Member
    • Total Post: 5
    • Newbie

    @Lavarius wrote:

    I know There hasn’t been many views for this, but i was able to come up with a package that performed the task I required. inside of a shell script that runs at login, run these commands:

    echo “before command”
    su – thinuser -f -c “gconftool-2 –set /apps/panel/global/locked_down –type bool true”
    su – thinuser -f -c “gconftool-2 –type list –set /apps/panel/general/applet_id_list –list-type string [,notification_area_screen0,window_list_screen0,notification_area_screen0,clock_screen0,mixer_screen0,main_menu_screen0]”
    su – thinuser -f -c “killall gconfd-2”
    su – thinuser -f -c “gconfd-2”
    su – thinuser -f -c “killall gnome-panel”

    works great on 11.1.031

    Would you mind giving a little more detail? I am fairly new Linux, especially Wyse’s implementation. What script did you put it in, and how did you edit it?

    #22885
    PCWyse
    Member
    • Total Post: 7
    • Newbie

    So to be clear, the menu bar was always hidden as thinuser? What device was this on?

    The reason I ask is I am trying to hide the menu bar. We are autostarting an ICA application via wlx.ini and we don’t want users wandering back to the T50 desktop. Maybe you’ve inadvertently helped me 🙂

    #22922
    Lavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    @ericgst: That’s the entire script I used, wrote it in vim. created the package using the instructions on creating new packages, that i believe are available somewhere on this site.

    @PCWYSE
    : No, it wasn’t that the menu bar was hidden, it was the Notification Area off to the far right on the menu bar wasn’t displaying the system settings icon. I haven’t had a need to completely remove the menu bar (called the gnome-panel i believe) but it seemed to be the gdm would always pick it up when i killed it and recreate the bugger. You might be able to edit packages in order to remove icons from there, but i have’t explored that. Looking at the script up there though, you might be able to edit that list, and remove main_menu_screen0, that could very well remove the menu icon on the lower left.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.