Newbie – cannot update firmware on C10LE

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6433
    bspies
    Member
    • Total Post: 18
    • Regular Joe
    • ★★

    Sorry for sounding like such a newb, but I am having a hard time getting my C10Le to update. We are piloting these, hoping to do a rollout of around 25-35 and allwas going well until I decided to upgrade to the latest ThinOS.

    The unit I have is on 6.5.0_23f

    I have my FTP and WDM servers apparently working. I can configure a legal notice, change wallpaper, create ICA connections etc etc. all via my wnos.ini. but, when I try and set AutoLoad=1 or 2 or 201 or anything other than 0 the resulting WNOS.INI I can see on the Wyse desktop iteself (right-click and “view INI settings”) shows autoload=0

    to make sure something else was not broken I have made other changes to the wnos.ini such as changing the DomainList and that works, as after a reboot I see the change I made. but for some reason when I change autoload that does not come down.

    Here is the first part of my INI. I have changed the server names of course:

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    AutoLoad=1
    Fileserver=cgywdm01.nowhere.pvt Username=anonymous Password=someone@nowhere.pvt
    Rapportserver=cgywdm01.nowhere.pvt Retry=3
    DomainList=domain02
    EnableLocal=yes
    S10WDMFlash=256MB
    PlatformConfig=CClass Firmware=C10_wnos BIOS=Enter BIOS filename here
    AdminMode=yes Username=admin Password=Wyseguyz
    Privilege=High HidePPP=yes EnableNetworkTest=yes ShowDisplaySettings=Yes EnableKeyboardMouseSettings=yes EnablePrinterSettings=yes SuppressTaskbar=auto KeepDHCPRequestIP=yes
    EnableGKey=yes
    EnableCacheIni=yes

    after re-reading this before posting it I noticed the BIOS part of PlatformConfig. I do not have a bios file, just the W10_wnos a sales engineer gave me. I have tried messing with this line a few different ways and it is not helping. I do see in the FTP logs attempts to get C10_bios.bin but I do not have one of those (that I know of).

    UPDATE: I have changed this line now: PlatformConfig=CClass Firmware=C10_wnos
    At this now I do not see references to download “enter” in my ftp logs (duh). but the upgrade is still not happening. Am I correct in assuming I really do need a bios file?

    Can anyone help a newb out?
    Thanks

    #19976
    ConfGen
    Keymaster
    • Total Post: 11409
    • Jedi Master
    • ★★★★★★★

    Delete these two line completely.

    S10WDMFlash=256MB
    PlatformConfig=CClass Firmware=C10_wnos BIOS=Enter BIOS filename here

    Also make sure the firmware file on your server is called C10_wnos and not W10_wnos as you’ve written above.

    Do you see the client looking for the firmware file – locally in the eventlog or on the FTP server?

    Are you using a mac.ini also?
    Have you tried to reset the client to factory defaults once?

    CG

    #19981
    aLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    You don’t really need to put “PlatformConfig=CClass Firmware=C10_wnos BIOS=Enter BIOS filename here” in your wnos.ini because the C10 will check by default to C10_wnos

    Just put the file “C10_wnos” in your ftp folder, also C10_bios.bin is not needed unless you get one from Wyse support.

    In your post you have a file called W10_wnos in your ftp folder not sure if this is a typo or not, but W10_wnos is not for the C10LE series.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.