Need help with username.ini

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #737
    Avatarinvisibleman
    Member
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    It’s me again…and thank you in advance for the patience.
    I have multiple thin clients on the floor that need to log onto an ica automatically like bar1, bar2, bar3 each with his own session so they don’t hijack each other’s.
    So far I have only one that is logging on using a wnos.
    I did some reading and found that it could be done by using a {username}.ini file.
    That’s where I got stuck. How do I do that and what should be my settings on both files?
    This is my Ica setting in wnos. I don’t have a username.ini yet:

    connect=ica
    description=”Login to Network…”
    icon=ica.bmp
    domainname=mydomain
    HttpBrowsing=1
    browserip=x.x.x.x
    application=”My Desktop”
    Username=myuser
    Password=password
    Fullscreen=1
    autoconnect=1
    LocalCopy=no

    Thanks

    #10769
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Here is one way to do this…

    connect=ica
    description=”Login to Network…”
    icon=ica.bmp
    domainname=mydomain
    HttpBrowsing=1
    browserip=x.x.x.x
    application=”My Desktop”
    Username=$TN
    Password=password
    Fullscreen=1
    autoconnect=1
    LocalCopy=no

    Now see the variable $TN, this is the terminal name. So what you could do is rename the terminal to Bar1 and it would log in as this as the username. It would mean renaming every terminal. There are other ways of doing an autologin,

    Cheers,
    -TT

    #10831
    Avatarinvisibleman
    Member
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Finally I got to it.

    I used the Username=$TN
    And it worked like a charm except that I need the password to be entered for me automatically as well.

    Is there a variable that will make it work?

    Thanks,

    Said.

    #10835
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    Hi Said,

    your already have the correct parameter for the password included (Password=).
    But to get autologin you also have to add the line
    Domain=xxxx
    where xxxx could be your domain or the local session (eg. XP Pro computername).

    Use my tool to get all available parameters in the correct usage.

    Regards
    ConfGen

    #10884
    Avatarinvisibleman
    Member
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    ConfGen,

    Please be patient as I am still not with it yet.

    You said I have to add “Domain=xxxx” does it mean an extra line beside the one that I already have “mydomain=mydomain”?

    #10885
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    Hi man,

    no. Mydomain is correct. I haven’t seen that when looking at your ini file the first time.
    So, autologin still not work for you? Are you sure that your terminal server is accepting autologin? Check your Terminal Servers Connection Settings to verify if it is always asking for a password.

    ConfGen

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.