Mapping USB storage when drive disabled with Group Policy

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6402
    charliecrackle
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    Have a custom written program running on Citrix XENAPP. need to get a photo of the customer from the wyse terminal to the application. have cameras that look like USB storage.
    User takes the photo and then plugs the camera into the WYSE terminal via USB.

    have the following in the wyse.ini file

    SessionConfig=ALL UnmapPrinters=no UnmapSerials=no MapDisks=yes
    SessionConfig=ICA DiskMapTo=U

    This is a very secure environment we dont want users to copy files from the citrix system.

    the citrix server is locked down to not allow MAPPED drives.

    this locked state has been changed to allow mapped drives ONLY to these terminals.

    the problem that we have that we noticed is if the user plugs a USB stick into the terminal they could copy data to and from the citrix server.

    To make this alittle more difficult for users we have used microsoft group policy to hide the “U” drive from explorer and my computer. this works fine and the program can still copy to and from the U drive and users can not see it.

    The problem we are having is the USB device has to be connected to the terminal before you log into citrix for it to work. If the user plugs the camera (USB STORAGE) into the terminal before logging into citrix all works as expected.

    If the user logs into citrix without the USB storage attached then when they plug in later the “U” drive does not exist.

    If I remove group policy there is a “U” drive displayed in my computer when the storage is not present before citrix logon and if you plug the storage later the U drive works as expected.

    The problem is it does not work with the group policy “Hide from my computer” option on when storage plugged in later but does work with group policy on with the storage plugged in before logon to citrix.

    Using a Windows ICA itrix client all works as expected

    Does any one know how to fix this problem

    You may have a better way to acheive what I am trying to acheive. we have the source to the program getting the photos off the storage. we tried getting the photos from \clientU but this again only worked if the storage was plugged in before logging onto citrix.

    Is there any other way to read the USB storage from the wyse termial without having a drive visable for users to copy file to.

    any help would be greatly appreciated.

    #19900
    aLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    We are using the Z drive for about the same purpose, the only difference is that we use a permanent Z drive.

    So for the wnos.ini it should look like this:

    Global Setting :
    SessionConfig=ALL UnmapPrinters=no UnmapSerials=no mapdisksunderz=yes

    Connection Setting (this would be ICA for you):
    Mapdisks=yes

    Now you will always have Z drive in your ICA connection/My Computer (i think you will hide it but you know what i’m talking about) once you have connected a USB massstorage device you can find your files in Z:D (D=first USB massstorage device) or \clientZ$D

    Ok, i’m not sure if you can replace Z with U or change your side from U to Z, but play around with “mapdisksunderz” parameter.

    #19905
    charliecrackle
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    Thanks this works under Z:D

    still does not work under u:

    Group policy must test the drive and z: is testable with no usb where u: is not testable with no usb

    Charles

    #19916
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    With WTOS all USB drives have to be attached before the session is started. Otherwise you won’t have access to the storage device.

    MapDiskUnderZ=yes would be the only alternative.
    But this is always Z: and is currently not changeable.

    CG

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.