Mapping serial port / com1 – Problems

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #850
    AvatarNick_G
    Member
    • Total Post: 41
    • Frequent Flyer
    • ★★★

    Here is the scenerio.

    I have multiple S10’s. I need to be able to connect a machine controller to the serial port on the S10, in order for software to send data to it. I need to do this with multiple S10’s and multiple machine controllers. Basically each S10 is connected to it’s own machine controller and each S10 logs on to our Citrix server using a different username.

    But i can’t even map the damn port. Using net use com1: \servercom1: does not work. System error 67, network name cannot be found.

    Using the change client com1: \servercom1: command… I’m getting “the specified network resource or device is no longer available.

    Am I even thinking about this right? Is there another way to do this that would make more sense? Any help would be MUCH APPRECIATED.

    Thanks ladies and gents!

    Nick

    #11323
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    It been a while and I am not at a machine to test but try:

    net use com1: \clientcom1

    Make sure the Citrix policy to map com ports is on on the server and the tick box ont he S10 to map serial ports is ticked.

    Also test from an XP to make sure com port re-directions works,

    Cheers,
    -TT

    #11337
    AvatarNick_G
    Member
    • Total Post: 41
    • Frequent Flyer
    • ★★★

    so \clientcom1 client being the server my s10’s connect to?

    #11340
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    Just use this command inside the ICA session.

    #11341
    AvatarNick_G
    Member
    • Total Post: 41
    • Frequent Flyer
    • ★★★

    Yea. Does not work inside ICA connection, but this works using RDP. I’m assuming this is a Citrix specific problem.

    #11342
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Yep, with citrix you need to set a policy to turn on the COM port mapping as its not on by default. Also you may have noticed the syntax is different to map the com port in the session than it is in RDP.

    http://support.citrix.com/article/CTX384590

    This may help,

    Cheers,
    -TT

    #11343
    AvatarNick_G
    Member
    • Total Post: 41
    • Frequent Flyer
    • ★★★

    Thanks TT, I’ll dig a little more. 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.