Login failes with 6.5.0_46F “Invalid username or passwo

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7133
    GhostRico
    Member
    • Total Post: 3
    • Newbie

    We have an 2003 Terminal server environment with like 80 S10/S50.

    We are in the proces of testing a upgrade from 5.3 to 6.5.0_46F.
    Just updated one terminal to see if we encounter problems and we do…
    When i login with my credentials it just makes the password field emty and green. It also gives me an “Invalid username or password”.
    The only option to retry logging in, is to reboot the wyse terminal.

    We have an 2008 R2 domain with de DC’s at service pack 1.

    It has something to do with authentication, but i can’t figure out where it goes wrong. The log itself gives me no clue.

    So, who has a solution?

    The wnos.ini file:

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=1
    Autopower=no
    AutoSignoff=yes Shutdown=yes
    shutdowncounter=0
    Privilege=low LockDown=no
    HideConnectionManager=No
    FormURL=logonmsg.gif
    DomainList=AD1
    ;*************************************************************
    ;* Audio *
    ;*************************************************************
    Device=audio
    mute=2
    ;*************************************************************
    ;* General 2 *
    ;*************************************************************
    Language=us
    ;Keyboard=us — United Stated English
    ;*************************************************************
    ;* Display *
    ;*************************************************************
    DeskColor=”255 255 255″
    Desktop=Firma.gif
    Screensaver=10 LockTerminal=no
    Resolution=DDC
    ;*************************************************************
    ;* Time *
    ;*************************************************************
    Timeserver=10.0.10.1 timeformat=”24-hour format” Dateformat=dd/mm/yyyy
    TimeZone=’GMT + 01:00′ ManualOverride=yes
    ;*************************************************************
    ;* Network *
    ;*************************************************************
    SignOn=NTLM
    DisableGuest=Yes
    EnableOK=yes
    DisablePassword=yes
    VncPassword=”something”
    VncPrompt=No Accept=
    ;*************************************************************
    ;* RDP *
    ;*************************************************************
    Connect=rdp
    Description=”TSCLUSTER”
    Icon=small.gif
    Host=tscluster
    Username=$UN
    Password=$PW
    Domainname=$DN
    Fullscreen=yes
    Autoconnect=no
    Colors=64k
    Lowband=no

    #21813
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Is your AD running in native mode or have you enable NTLM authentication?

    CG

    #21816
    GhostRico
    Member
    • Total Post: 3
    • Newbie

    Yep, the domain is running “Windows Server 2008 R2” on both domain functional as Forest functional level.

    The “old” NTLM setting was already set:


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetservicesLanmanServerParameters]
    “enablesecuritysignature”=dword:00000000
    “requiresecuritysignature”=dword:00000000



    What i did discover is that when i set the parameter SignOn=yes I could login. I did not test this with the older versions how the responded.
    But, the “you can login as guest” returned and the option to fill in a domainname was gone.

    How secure is this?
    Where did it get the domain name for the login?

    Thanks in advance for the support.

    Rico

    #21833
    GhostRico
    Member
    • Total Post: 3
    • Newbie

    Small update:

    Changing setting “SignOn=NTLM ” to “SignOn=yes ” and modified the .ini file with a static domain name (not a variable) you can get it to work.

    But… (as always), if i would like to use someone else his config file, it can be done.

    If I type a username and no, or any password I get the user configuration for that user in the .ini file and the loginscreen of the terminal server.
    There I type my own credentials and there you go…

    If you type the correct username and password you will automatically logged in, the credentials will be passed thru to the RDS server.

    With firmware 6.5.0_46f it does seem to work with RDS on Windows 2008 R2 with the session broker. If you lose the session it will reconnect to the open session somewhere in your RDS farm. Even if you go directly to a RDS server that does not host your session, you will be redirected.

    I don’t expect that it will work with the gateway services from somewhere on the internet.
    Maybe in later tests 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.