Login error ThinOS 9.1

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #73672
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    I have upgraded two Wyse 3040 units from 8.6 to 9.1 to test things out before deployment. When a user tries to login to Thin OS after the unit has been idle (without any user logged in) for a while the user is met with the error “The session is has expired, please try to log in the broker.” It the user tries again it works. When the user disconnects the session ThinOS logs out as configured. But when the next user comes after a while, the error message is shown. How can I avoid this error message showing after the unit has been left idle in logged out state for a while?

    #74170
    vdoussetvdousset
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Hello Peter,

    I’ve got the same problem when i tried to upgrade directly 8.6 to 9.1.

    So I update 8.6 to 9.0 and after 9.0 to 9.1 and it’s ok now.

    regards.

    #76109
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    So I have to downgrade the 3040 units to 8.6 and then upgrade them first to 9.0 and then to 9.1 in order for them to work? How do I do that? My 3040 units do not boot from the USB-images I have created with the USB Imaging Tool 3.4.0. The stick only boots my 5070 units. Can I downgrade them through WMS 3.1?

    #76110
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    The USB Imaging Tool is not hardware dependent.
    Just make sure that booting from USB is allowed in the BIOS.

    CG

    #76111
    vdoussetvdousset
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    You have to disble the secure boot in the Bios.

     

    #76206
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    Thanks for the help with secure boot. This enabled me to downgrade to 8.6.013. I then upgraded to 9.0.4024. Also in version 9.0.4024 I get the error message “The session is has expired, please try to log in the broker.” When the log in screen is idle for a while. Is the login screen creating a session that then expires? Should not the session start when credentials are entered and the user logs on to ThinOS? Is there a setting for this in WMS that I have missed?

    #76277
    Avatartoby
    Participant
    • Total Post: 4
    • Newbie

    I can confirm that behavior with 9.x, the only way is to enable the option “Direct External Connection to the NetScaler/ADC (no beacons being used)”, but then all connections are forced through the netscaler.

    My current workaround is to specify the internal storefront.

    I am not happy with that.

     

    #78142
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    When the login screen comes up it says “Starting broker sign-on” for a second and then “Waiting for credentials to login”. This means that a session is started when the login screen is shown. If I look in the logs of the client it says [StoreFront] user authorize ” https://serveradress/Citrix/Authentication/ExplicitForms/Start ” This means that a session is created when the login screen is shown and if the user does not sign in within a short while after this the sessoin expires and the user has to sign in twice. NetScaler is not used for our direct connections so using  the setting for “Direct External Connection to the NetScaler/ADC (no beacons being used)” did not change this. How can I change this behaviour of the client? In 8.6 the session was not started until the users entered their credentials.

    • This reply was modified 2 months, 3 weeks ago by PeterPeter.
    • This reply was modified 2 months, 3 weeks ago by PeterPeter.
    #105108
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    This issue still persists with ThinOS 9.1.2021 and the latest Citrix package unfortunately.

    #105109
    Avatarbrian1020
    Participant
    • Total Post: 186
    • Jacked into The Matrix
    • ★★★★★★

    What is the format of your broker URL?

    I’m having no trouble using https://myCitrix.com/Citrix/StoreName

    if you leave the url without /Citrix/StoreName what happens?

    Usually you have to select the store from a pop-up

    Is the authentication type Default, LDAP, MFA?

    #105113
    Avatarmoose09876
    Participant
    • Total Post: 9
    • Regular Joe
    • ★★

    For ours, if you hit escape it should reload the broker and allow you to log in. I’m just taking this as a training point for our end users to do that prior to logging in.

    #105114
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    The address is https://myserver.se/Citrix/store so the same as you mentioned.

    #105115
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    Yes, that is a way to abort the expiered session and allow login. But this is an unwanted behavour. I cannot have my users pressing escape every time they login to trigger a new valid session with the broker. Why is the session promted directly after the last user has logged out? This should be done after the user has entered their credentinals in my opinion.

    #105116
    Avatarbrian1020
    Participant
    • Total Post: 186
    • Jacked into The Matrix
    • ★★★★★★

    What your describing sounds like Azure MFA SAML where the “browser lite” pops up from the federated services page on top of the ThinOS login box?

    Eventually the federated services page expires and disappears and as you’ve said, you can hit Esc or Enter to get it to pop up again. Is that accurate?

    #105117
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    No, this is in Citrix, so not i WVD or RDS-setup. It is the “native” ThinOS login screen. What happens is that when the client starts you briefly see the text “Starting broker sign-on”. And then it waits for credentials. If the client stands idle for a while (less than 30 minutes) and you try login it says the session has expiered. If you instead press escape, you trigger the screen to again “Starting broker sign-on” which means that the ThinOS client probably gets a new session from the broker and thus sign in works.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.