KeySequence Problem with Ctrl+Alt+Del

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1665
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    I upgraded V10L to the first version that supported keySequence, 6.0.1_09

    I upgraded v10L to that version from 6.0.1_04. But with all versions 09 and up, everything in the KeySequence parameter can be locked down except Ctrl+Alt+Del.

    I know the KeySequence parameter is being accepted because there is no error and left, right, up down are indeed disabled. But it doesn’t matter iof I have Ctrl+Alt+Del set for yes or no, I can;t lock this feature down. I tried in 6.0.1_09, 6.0.1.14, 6.2.0_16 (the latest). No dice. Actually, there’s a ICA bug in 6.2_0-16 that trashes my OCA connection that is served up in ini . . .so I didn’t really get that far in that version.

    Wyse looked at my ini, verified it all should work and bumped it up to level 2 support. Still waiting on answer. Any help from you kind folks???

    #14741
    ConfGenConfGen
    Keymaster
    • Total Post: 11002
    • Jedi Master
    • ★★★★★★★

    Post your wnos.ini.
    Do you have any GPOs applied? What PS version?
    What language?

    CG

    #14749
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    WYSE acknowledged the problem. They put it in the bug report.

    I am currently running 6.0.1_14. The Ctrl+Alt+Del fiales to lock with either yes or no from 6.0.1_09 on up! (I didn’t get that far on latest 6.2.0_16 because that trashed my ICA connection – it’s an acknoledged bug in that version.

    Here’s the ini. Note that the Ctrl+Alt+Delhas been tried both ways just in case the logic is different. When I try it in your Generator, I check all of them (Up, down, left, Right and the Output shows the Ctrl+alt+Del as yes and everything else as no. I have tried it both ways. No difference. But the prerameter IS being read and there is no error – either way. It’s frustrating. I think you know I have been broght kicking and screeming into this Wyse World and now that I am feeling pretty comfortable, this bug keeps me from being able to delply 30 V10L units!

    Fileserver=xxx.xxx.xxx.xxx Username=admin password=admin1

    AdminMode=yes Username=admin Password=letmein1

    Privilege=None Lockdown=yes HideSysInfo=yes HidePPP=yes HidePN=yes HideConnectionManager=Yes ShowDisplaySettings=No

    autoload=1

    KeySequence=yes Ctrl+Alt+Up=no Ctrl+Alt+Down=no Ctrl+Alt+Left=no Ctrl+Alt+Right=no Ctrl+Alt+Del=no

    Customer=walmart
    HideIP=yes

    EnableGKey=yes

    AutoPower=yes

    DhcpExpire=reboot

    Resolution=1024×768
    Screensaver=”20″

    SignOn=No

    CONNECT=ICA
    BrowserIP=xxx.xxx.xxx.xxx
    Application=”Application”
    Description=”App1″
    AutoConnect=1
    Fullscreen=yes
    Logon_Mode=user-specified
    Username=$TN
    Password=letmein1
    Domainname=xxxdomain
    Alternate=yes
    HTTPBrowsing=yes
    LocalCopy=no

    #14750
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    No GPOs applied. Don’t even know what “PS” is

    It’s interenting that Wyse tried to tell me that for them, it seemed to block it when Ctrl+Alt+Delete was actually pushed, but not Ctrl+Alt+Del (i.e. the delete under insert but not the del that’s part of the number pad).

    Either way, they said that the ablity to get to shut down screen should be totally blocked and it isn’t

    But for me with either yes or no, I could not block either Ctrl+Alt+Del or Ctrl+alt+Delete. How long might I have to wait on a fix to be encorporated . . .that’s the real headache for me.

    Umm…. whatever else happens, Merry Christmas!

    #14752
    ConfGenConfGen
    Keymaster
    • Total Post: 11002
    • Jedi Master
    • ★★★★★★★

    PS = Presentation Server.

    Here is my wnos.ini which I have tested it with. Works perfectly for me.

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 4.6.09 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* http://www.technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=1
    EnableLocal=yes
    Privilege=High

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=De
    MouseSpeed=1
    KeySequence=yes Ctrl+Alt+Up=no Ctrl+Alt+Down=no Ctrl+Alt+Left=no Ctrl+Alt+Right=no Ctrl+Alt+Del=yes

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Desktop=wallpaper_1280x1024.jpg
    Screensaver=”10″ LockTerminal=no Type=2 Image=screensaver.jpg
    DesktopColorDepth=32

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=ntp0.pipex.net Timeformat=”24-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT + 01:00′ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=”W. Europe Standard Time” DayLightName=”W. Europe Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    SignOn=no
    DomainList=wdm
    MaxVNCD=1

    ;*************************************************************
    ;* Printing *
    ;*************************************************************

    Printer=LPT2 Name=”HP” PrinterID=”PSC 2200 Series” Enabled=yes

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL MapDisks=yes

    #14753
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    so, You are saying that on a V10L, the config file you run with the Ctrl+Alt+Del=yes will deny the user th ability to get to a dialogue where they have optin to shut down or shut down and restart?

    Then what other factor is going on that we AND the WYSE support are not seeing?

    They verified by ini file and confirmed the issue and then bumped it up to a 2nd tier of support. They responded and said it is indeed a bug?

    I don’t try to test the KeySequence until after the ICA session has loaded but when I do, Ctrl+Alt+Del is NOT disabled. I can try actually typing the CTRL+ALT+DEL or CTRL+ALT+DELETE when I have the CTRL+ALT+DEL=yes in the ini, and it is not disabled. And if WYSE sees the problem, and you don’t, then where is the variable we have missed? A Bios version??

    On what version of Thin client were you seeing it work correctly? And what device are you using??

    BTW PS is 4.5

    #14754
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    ONce again, I reset v10L – Ran the following ini

    Fileserver=xxx.xxx.xxx.xxx Username=admin password=admin1
    AdminMode=yes Username=admin Password=letmein1
    Privilege=None Lockdown=yes HideSysInfo=yes HidePPP=yes HidePN=yes HideConnectionManager=Yes ShowDisplaySettings=No
    autoload=1

    KeySequence=yes Ctrl+Alt+Up=no Ctrl+Alt+Down=no Ctrl+Alt+Left=no Ctrl+Alt+Right=no Ctrl+Alt+Del=yes

    Customer=walmart
    HideIP=yes
    EnableGKey=yes
    AutoPower=yes
    DhcpExpire=reboot
    Resolution=1024×768
    Screensaver=”20″
    SignOn=No

    CONNECT=ICA
    BrowserIP=xxx.xxx.xxx.xxx
    Application=”Application”
    Description=”App1″
    AutoConnect=1
    Fullscreen=yes
    Logon_Mode=user-specified
    Username=$TN
    Password=letmein1
    Domainname=xxxdomain
    Alternate=yes
    HTTPBrowsing=yes
    LocalCopy=no

    When it over, I see the Citrix application on full screen.

    Ctrl+Alt+left/right/up/down does nothing. Either entering Ctrl+Alt+Del
    or Ctrl+Alt+Delete takes me to the shut down screen and is not disabled like the up/down/left right are.

    On Monday I am going to try removing the G Key and also the customer=walmart and see what happens. I can’t remember what the customer=walmart is except it was some kiosk alteration that Walmart asked for. Maybe there’s some sort of a conflict there?? Even though nothing errors and WYSE said nothing about it when they analized my wnos.ini and said they could duplicate it.

    I am at an absolute loss otherwise. But obviously, if you are getting it to work on a v10l and I am not . . . .there’s a problem that even WYSE did not realize.

    #14755
    ConfGenConfGen
    Keymaster
    • Total Post: 11002
    • Jedi Master
    • ★★★★★★★

    Can you try with my wnos.ini for a test? Set customer=wyse to get rid of the walmart specific things. Or do you work for walmart?

    CG

    #14758
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    Yes, I will give it a try Monday. I will not be back at that location until then.

    No, I don;t work for Walmart. After I first was dumped into WYSE world (You remember—you helped me along) I was trying to lock things down using different means. And in one of the OS versions there was a customer=walmart tag that was supposed to do something to lock things down. But your right, I should remove it. Maybe there’s some sort “This trumps that” conflict going on that WYSE didn;t notice.

    I’ll post the results here later Monday.

    Thanks

    #14760
    ConfGenConfGen
    Keymaster
    • Total Post: 11002
    • Jedi Master
    • ★★★★★★★

    VERY STRANGE THINGS HAPPENING HERE….

    I have tried your wnos.ini here and could replicate your issue. But now, after using mine again, CTRL+ALT+DEL is still working although disabled in my wnos.ini.

    Looks liek something has broken this parameter and the unit is still aware of this. Even a Reset to factory defaults did not help.

    #14761
    ConfGenConfGen
    Keymaster
    • Total Post: 11002
    • Jedi Master
    • ★★★★★★★

    NOT STRANGE ENOUGH.

    Looks like I have found it.
    Try setting customer=wyse instead of walmart and reboot.

    Looks like this parameter is breaking everything. Only resetting it via =wyse is possible..

    Give it try on monday.

    CG

    #14762
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    yep, that did it! I wonder why WYSE dodn;t bring that up when they inspected my ini file?

    Well there’s still a “bug” but maybe not. Now, with Customer=wyse, CTRL+ALT+DELETE os locked, but CTRL+ALT+Del shows the windows server 2003 shut down screen and info, although everything is greyed out except for the cancel button.

    I will report this to Wyse I would lile to see entering Ctrl+Alt+Del or Ctrl+Alt+Del resul;ting in the same effect, i.e. no change in screen.

    I think that is what WYSE was trying to tell me all ready. They saw it working in one instance but not the other and reported that up the bug as a chain. I kept trying to tell them that there was something else going on because they were not getting the same results as me.

    Thanks. This is good enough to deploy these uinits I think.!

    #14763
    ConfGenConfGen
    Keymaster
    • Total Post: 11002
    • Jedi Master
    • ★★★★★★★

    Say hello to Wyse from me and let them know that FWM found the issue 😀

    CG

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.