Invalid CONNECT Parameter: Mapdisksunderz=no

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #914
    Avatarjoelgibby
    Member
    • Total Post: 3
    • Newbie

    Hello,

    Back in August of 07, we upgraded our 1200LEs to the 5.2 firmware and have been happily taking advantage of the USB drive mapping functionality it enabled. A few days ago, some of our users reported not being able to access their USB drives anymore. When we first turned on the drive mapping functionality, we had to use the Mapdisksunderz=no connect parameter because our users have a network Z: drive mapped. I don’t remember seing an error stating that the parameter was invalid before, but today the 1200’s event log says: Invalid CONNECT Parameter: Mapdisksunderz=no . The disks do get mapped under Z for users without the network Z already mapped. Users that already have the network Z mapped do not see their USB drives. Any ideas anyone?

    Thanks for this great resource. It’s here that I first heard that the 1200LEs could be upgraded. It breathed another 2 years at least into the hardware.

    #11628
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    Hi,

    never heard that a parameter is not working anymore without any changes.
    To further troubleshoot please check the firmware on the units and post it here.
    Also post your wnos.ini file. Both helps us helping you.

    Regards
    CG

    #11630
    Avatarjoelgibby
    Member
    • Total Post: 3
    • Newbie

    Firmware version: 5.2.0_40

    WNOS.INI:

    Privilege=None
    signon=0
    autoload=1
    formurl=camas_newlogo.bmp
    Desktop=camas-desklogo.bmp
    DeskColor=”128 128 128″
    connect=ica
    description=”Desktop [800×600]”
    icon=default
    Mapdisks=yes
    Mapdisksunderz=no
    username=””
    password=””
    domainname=intranet
    browserip=ctxa-01
    application=csd-desktop
    autoconnect=0
    Encryption=Basic
    Fullscreen=yes
    Resolution=800×600
    connect=ica
    description=”Desktop [1024×768]”
    icon=default
    Mapdisks=yes
    Mapdisksunderz=no
    username=””
    password=””
    domainname=intranet
    browserip=ctxa-01
    application=csd-desktop
    autoconnect=0
    Encryption=Basic
    Fullscreen=yes
    Resolution=1024×768

    Thanks for the quick response!

    #11640
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    From the first checking your wnos.ini looks fine to me.
    Have you tried to create a ICA connection locally on the unit? Will it also fail to map the USB drives correctly?

    #11643
    Avatarjoelgibby
    Member
    • Total Post: 3
    • Newbie

    Interestingly,

    I loaded the ini file into your infinitely helpful ConfGen utility, added:

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL MapDisks=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    SessionConfig=ICA DiskMapTo=EFGH

    And everything seemed to work after that. It looks like (even though the WNOS.INI documentation states otherwise) the MapDisksUnderZ parameter is not a CONNECT parameter, and it may not have mattered. Oh well.

    #11644
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    Shit, you are right.
    I didn’t see that you’ve used MapDiskUnderZ inside an ICA connection.
    This is definitely not a session parameter.

    Good to know that everything works now.

    CG

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.