Installing networked printers on WES7 device

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7093
    Psalwey
    Member
    • Total Post: 6
    • Newbie

    Hey all,

    I’m having issues getting a networked printer to install on the device. I’ve deployed packages containing a script that will install the printer, but after it runs the printer does not show up in “Devices and Printers” for the user account- it will show up when I log in as administrator.

    Are there some settings I need to change, maybe in the Local Group Policy Editor, to make this printer install?

    To make sure it wasn’t the package/script that wasn’t working, I logged in as administrator and typed into the CMD prompt what my script (batch file) does.

    It just doesn’t take. I’ve tried a number of things, such as disabling prompt to “trust” the driver and make the installation as seamless as possible, along with the command (after net use command to authenticate to printserver) :

    start \printservernameprinter /ga (/ga to make the printer install for all users on device)

    Even manually installing it only works for the administrator, not when I get back onto the user account.

    Anyone else ever have this issue and how did you resolve it? Thanks

    #22676
    MoreWyseKnowledgeTY
    Member
    • Total Post: 5
    • Newbie

    Psalwey,

    My environment consists of a lot of C90LE7 (WES7) and some C90LE (Win XP) models. There are four servers total in our Remote Desktop Services (RDS) farm. One is for load-balancing, licensing, and session brokering. The other three are the servers that clients actually connect to. This environment is not part of my companies domain. It is on the same network and consists of five different groups (five different subnets). Wyse Device Manager 4.8.5 is running in this set-up as well.

    I have been experiencing the same problem you have with certain users. They cannot connect to a networked printer. I’ve loaded the appropriate drivers to the print server, as our RDS grabs device drivers from the print server for the thin clients. Everyone should be able to print to any printer on the network. Like you, I can log onto the client with my administrator credentials and connect to and print to the exact printer the user is having problems with. When they log back on, they cannot print due to the thin client not being connected to the printer.

    I have restarted a few resulting in them being able to connect to the problem printer. However, later, they cannot connect to the printer again.

    This is very frustrating and inconvenient. It happens to random users, and random thin clients. Anyone’s input here will be helpful.

    #22833
    Heagz
    Member
    • Total Post: 29
    • Frequent Flyer
    • ★★★

    I’m not sure if it will work on WES7, but it has worked in XPE in the past for me. Have you tried to use the rundll32 printui.dll, PrintUIEntry command to install them? I think Microsoft has a pretty good knowledge base article on this. You can install the printers “per machine” and should apply to all users. It’s worth taking a look at, just not sure about the WES7 compatibility…However, when you install using this, sometimes you have to run the command to remove them again, and a reboot is required to get them removed. You may still see them after a reboot, but they should disappear if the deletion per command was run prior to rebooting.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.