http/https Instead of FTP

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5474
    taylward
    Member
    • Total Post: 7
    • Newbie

    At one time, I read where WTOS supports http/https to pull down the wnos.ini instead of FTP.

    I can’t seem to get it to work.

    Does anyone know the exact syntax required, or point me towards a white paper – I can’t seem to get it to work.

    #17032
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★
    #43496
    Miorky
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Hi CJ,

    I tried to set this up in 5.7.1. Do you have for me the link to the article. The old url doesn’t work anymore

    #43499
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    If you use WDM 5.7.1 your IIS is already using SSL. You should only add “https://” to the fileserver entry on ThinOS.
    Also make sure there is a MIME setting on your IIS for .ini (Text/PLain) and . (Text/Plain).

    CG

    #43516
    Miorky
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Unfortunately, its still no good. HTTPS can’t approach the systemprofile.

    Current situation:
    WDM 5.7.1
    When powering on a Thin client, it get a IPadres in our guest VLAN. He gets a reference to the WDM using DHCP server. Here is a folder (C:\inetpub\ftproot\2016-10\wyse\wnos\cacerts) with CA certificate. The thin client retrieves the certificate and after reboot the thin client will sign up in the production VLAN and retrieves the WNOS updates over FTP (C:\inetpub\ftproot\2016-10\wyse\wnos). This is now the working solution.

    DHCP entry’s
    161 FTP Update location  10.200.9.146
    162 FTP Update directory  /2016-10

    New situation over HTTPS:
    WDM 5.7.1
    When powering on a Thin client, it get a IPadres in our guest VLAN. He gets a reference to the WDM using DHCP server. Here is a folder (C:\inetpub\ftproot\2016-10\wyse\wnos\cacerts) with CA certificate. The thin client retrieves the certificate and after reboot the thin client will sign up in the production VLAN and retrieves the WNOS updates over HTTPS from the folder C:\inetpub\ftproot\2016-10\wyse\wnos

    DHCP entry’s
    190 WDM Server Secure Port  0x1bb (443)
    194 WDM FQDN Name  servername.domain

    MIME setting as you mentioned where set.
    System Setup – Central Configuration – Fileserver on the thin client  MYWDM/RAPPORT/2016-10

    I tried to use the following setting, the same as with FTP. This is not working. Can not find system profile
    162 FTP Update directory  /2016-10

    I tried to use the WNOS setting within WDM. WTOS preference – WTOS root Path: 2016-10. I copied the C:\inetpub\ftproot\2016-10\wyse\wnos to C:\inetpub\ftproot\Rapport\2016-10. Still can not find system profile

    #43517
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    Change OT 161 to “https://servername.domain” (your server hosting the ini file).

    CG

    #43527
    Miorky
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Hi CG,

    I’ve changed OT 161. And still get the same error. I tried it with WTOS preferences checked and with WTOS preferences unchecked and OT 162 pointed to the location. Both way’s it can’t find the certificate location. Thin client are checking-in correctly in WDM

    https://s17.postimg.org/kbswjdxqn/image3.jpg
    https://s17.postimg.org/il9vhwg7j/image4.jpg

    #43528
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    What exactly do see now in the Fileserver field on the Thin Client?
    Can you access the /rapport/2016-10/ folder from a browser AND see the wnos.ini by entering
    https://10.200.9.146/mywdm/Rapport/ and https://10.200.9.146/mywdm/Rapport/wnos.ini?

    CG

    #43531
    Miorky
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    I can access the location by https from other servers in the same test enviroment after entering my credentials

    https://servername/MyWDM/2016-10/wyse/wnos/wnos.ini
    https://servername/MyWDM/rapport/2016-10/wyse/wnos/wnos.ini

    The location on the thinclient fileserver field is: https://ipadres/MYWDM/rapport/(not visable)

    https://s12.postimg.org/k802yj9ml/image1.jpg

    #43535
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    And you are logging in a user rapport when testing from a different machine?

    CG

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.