Final ini tweeks V10L

  • This topic is empty.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1593
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    my wnos.ini is almost complete. There are a couple of things I want to tweak if possible and I am a bit confused on some of the logic.

    1. THis V10 serves up a Citrix Applciation and does nothing else. I am having problems disabling Ctrl-Alt-Up and Ctrl-Alt-Down.

    Once someone is on the Citrix Desktop, the only thing I want them to be able to do is use mouse/keyboard and possibly reboot the V10L. Actually, I don’t mind them being able to minimize the connection and seeing the desktop- – – and it seems like that would have to be done if there’s no other way to gain admin control other than by right clciking on desktop.

    But I don’t like the way the IP address shows on the ICA session is minimimized. Is there any way not to allow that?

    If my only option is to completely “kiosk” the whole thing so there is only recylce power available, I would rather this than having them see IP address. Then, baring access to admin mode other than desktop right click, I realize my only option would be to Enable G Key.

    I have tried inserting KeySequence=Yes and Ctrl+Alt+Up=no Ctrl+Alt+Down=No, etc . . .but I get an error then. (commented out, below)

    2. I don’t mind them rebooting (perhaps) but I would rather them not be able top power down.

    I’m light years ahead of last week! Thanks for the assistance.

    *************************************************************
    ;* General 1 *
    ;*************************************************************

    Fileserver=192.168.1.12
    Rapportserver=192.168.1.12
    AdminMode=yes Username=admin Password=wis3
    EnableGKey=yes
    Privilege=None Lockdown=yes HideSysInfo=yes HidePPP=yes HidePN=yes HideConnectionManager=yes
    ;KeySequence=yes Ctrl+Alt+Up=no Ctrl+Alt+Down=no Ctrl+Alt+Left=no Ctrl+Alt+Right=no Ctrl+Alt+Del=yes

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=1024×768

    ;************************************************************

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    SignOn=No

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    ;


    ;- ICA Session 1 –
    ;- Each line but the last must end with a ” –
    ;



    CONNECT=ICA
    BrowserIP=xxx.xxx.xxx.xxx
    Application=”App Application”
    Description=”App Connection”
    AutoConnect=1
    Fullscreen=yes
    Logon_Mode=user-specified
    Username=WWCC05
    Password=wis3
    Domainname=win1
    Alternate=yes
    HTTPBrowsing=yes
    LocalCopy=no

    #14440
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    Hi mixer1,

    great progress.

    1. What error do you see?
    2. try adding this:

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    Autopower=yes
    AutoSignoff=yes Reboot=yes
    Shutdowncounter=5

    CG

    #14447
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    I also found HideIP will hide the IP address of mouse over a minimized ICA connection. Duh!

    I will send you the Key Sequence error I get when I am back there Monday.

    I can store privilege info and ICA info locally, and then, with LockDown=yes, I can get most of the same feel on the local machine, but it looks like it wont’ do HideIP without the ini file to read. The only thing it appears to save locally is the priv. settings, yes?

    #14448
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    You can store a lot more info locally by using “EnableLocal=yes” for global parameters and “LocalCopy=yes” inside session definitions to store the sessions (ICA and RDP)

    CG

    #14458
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    ouch! I had to move the ftproot/wdm install to a different box and move the V10L so I can access it easier as I work things out. When I did so, I could no longer work on wnos ini. I thought I had a clear enough understanding of everything . . . . but I am still somewhat befuddled by some of the path and the interrelation between wdm and the v10l. Please check out my setip. The ini I am using is the same one posted earlier in this thread.

    1. WDM 4.7 installed on XP SP2. I can see v10L device in device manager. Ftproot is set up with default settings and WDM install places a Rapport directory within ftproot

    2. I do a test on MASTER software Repsotory set up via SQL service manager (created during wdm installation) and it passes

    3. In WDM preferences, WYSE THinOS I have Enable Return of FTP INI but no root path set up.

    4. On the V10l Desktop I point it to 192.168.1.12 for ftp and same for Rapport. I put nothing else in. this screen

    5. Once I reboot v10L it fails to connect, but the username Rapport and a password has been insrted automatically. I assume this is via WDM? I can never put it in on my own because I don’t know it’s password.

    I don’t know that password. Why??? Is it propriatary to the WDM?

    FTProot it set up as default. Under ftproot there is a Rapport dirrectory. I have a ini file in that rapport there that should work. I still don’t understand the creating of the wnos directory, so I have hedged my bet by creating a wnos directory under Rapport and placing the same ini file in it.

    What on earth am I doing wrong??

    Help. Even when I had things running lastweek, it seems like I had to go thru several “try this” and “try that” when I reset box to factory settings bbefore I could read wnos.ini. Thank you so much!

    #14459
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    Just disable the WDMs “Enable return of….” completely.
    Even without a named root path WDM will change the username and password of the ftpuser. This will result in the unit checking for the new rootpath ftproot/rapport even you do not see this. This is because the user Rapport has this as his “hardcoded” rootpath.

    BTW, rapport password is “r@p8p0r+” 😉

    Cheers
    CG

    #14473
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    Hmmm . . .

    Ok, Here’s what I did.

    1. Removed the check in “Enable return . . .” in WDM. Leave wdm running

    2. ON V10L I reset to factory defaults/reboot

    3. It comes back, can’t connect intially. I expect this because It defauults to 192.168.1.1 But my xp workstation running ftproot is 192.168.1.12. It also inserts anonymous user in by default.

    4. I change IP of fileserver in V10 Network tab and also ad the wdm server, both 192.168.1.12. I leave anonymopus user/password alone and reboot.

    5. It comes back up, still cannot load profile. No other error in event log Iverify WDM box and V10 can ping each other.

    6. I go back into V10 Network settings and it has automatically replaced anonymous with rapport. I reboot. Still cannot load profile. No other error in event log

    BTW, your password for rapport does not seem to be correct. In point 6, if I remove password for rapport and reboot, it comes up asking me for password. If I put password in exactly as you have it, it will not accept.

    Also, I have WDM running during all this and after each reboot, WDM sees the device.

    Thank you so much. I’m stumped.

    #14476
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    So the only thing that changes during a reboot (after the IPs are right) is the ftp user and password? Do you use any DHCP option tags?
    What fileserver/path do you see locally on the unit?

    CG

    #14488
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    Once I put the correct IPs in and reboot, I see those IPs the next time I check network Setup. In addition, the event log only tells me it can;t access the profile. it doesn’t tell me it can’t access the servers (ftp and Rapport)

    I know this because I *DO* see it error on the fileserver after initial reset/reboot, until I change the IPs to the cioirect address.

    I am not using dhcp tags. ftp box has a static IP .12. I can ping ftp box from V10L. If I disconnect ftp box, ping fails.

    I can also ping V10L and remember, V10L shows up each time in device management in WDM.

    I have the same wnos.ini running that I posted earlier here. I have it sitting in two places ftprootrapport and ftprootrapportwnos

    I test a connection to the sql in WDM and it works fine. I try replacing rapport and it’s password with administrator credentials, and still no profile access.

    Thanks

    #14492
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    Can you login with rapport/r@p8p0r+ from your XP machine to your FTP server from a command prompt? (eg. cmd followed by “ftp ip-address”)

    CG

    #14510
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    Good idea. Yes I can.

    #14511
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    I have *Finally* got the higher up on the WAN to agree to a ftp server as part of the day to day. So, for me, this issue has become moot.

    However, they are relying on me and some of my experience over the last few days (Scary, huh?).

    Can you confirm a couple of things for me before I put this to rest??

    We still will not be using dhcp tags. (Multiple DHCP servers running on different routers in a wan environment)

    If we set everything up on an ftp server and I just put that ftp ip user and password in a default V10L, it should be able to connect fine. Correct? WDM does not need to be installed, somewhere, managing the connection, does it? It can get along fine without WDM right?

    I would still try to figure out my connection issue, but I sold them on it by confirming that HideIP and KeySequence lockdown are ONLY Available via wnos.ini and these features cannot be stored locally.

    #14513
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    Hi Mixer1,

    If we set everything up on an ftp server and I just put that ftp ip user and password in a default V10L, it should be able to connect fine. Correct?

    Yes

    WDM does not need to be installed, somewhere, managing the connection, does it?

    That’s correct

    It can get along fine without WDM right?

    100% correct

    Cheers
    CG

    #14514
    AvatarMixer1
    Member
    • Total Post: 35
    • Frequent Flyer
    • ★★★

    THnank you so much. Your help has been great. Once we have these in place I will have my own V10L to play with, and I will do much more than a simple (albeit not for me, initially) citrix connection!!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.