Error sending lateset XPe image

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #129
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Hi,

    When i try to send the latest XPe image from Rapport to a terminal, it reboots begins to PXE boot and connects to the server but stops with the error…

    ‘Searching for Interface…+-(HTTP)… OPEN Failure’

    It then repeats ‘OPEN Failure’ four more times and then it fills the screen with…

    ‘Launch Attempt (xxx) ‘ftp//rapport:r@p8p0r+@xxxxx/Tools/sa/root.i2u’ : File Open ERROR for /root.i2u… Unable to continue’

    I have connected manually using FTP to check the connection and it works fine and i have ensured that the Rapport user has FULL access to the inet folder.

    Any ideas? This has only stopped recently.

    Cheers.
    Darron

    #8665
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    I saw this once with Rapport installed on XP Pro. When I checked the event log on the PC it had the “you have excedded 10 connections” error. What was happening was Windows was droping the connection as XP Pro would not allow any more connections to the box.

    Can you provide any more info on the setup, what version of Rapport, the OS its on, any post installation hotfixes and event log errors,

    Thanks

    #8666
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Cheers Thinkthin for the promt reply.

    I am running on a windows 2003 box with SP1 (Rapport was installed pre SP1) and i have installed the Wyse hotfix.

    I have checked the event logs and there are no errors listed.

    I have checked the IIS logs also and they are of no use.

    Cheers
    Darron

    #8667
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Have a look in the event log and see if there is any errors in there relating to the hservice or IIS. Check and make sure IIS is running correctly. SP1 in Windows has a feature that will stop IIS running unless you allow it (DEP), make sure this is disabled or allows rapport/IIS.

    Also is this the only thing using IIS? Make sure only Rapport is using IIS on that server. I will send you a hotfix to test too as you are a member,

    Cheers,
    -TT

    http://support.microsoft.com/kb/875352

    #8668
    AvatarAnnu
    Member
    • Total Post: 5
    • Newbie

    I think u didn’t set the DHCP parameters (Add DHCP option) in the DHCP Server for the Rapport 4.4.1, u will have to add three parameters in your DHCP Server in server option 1. 015 DNS Domain Name “your fully qualified domain name or server name” 2. 043 Vender Spacific Info “0x0” 3. 067 Bootfile name “rapportitf.0”, lets try and tell me what will happen.
    @Darron wrote:

    Hi,

    When i try to send the latest XPe image from Rapport to a terminal, it reboots begins to PXE boot and connects to the server but stops with the error…

    ‘Searching for Interface…+-(HTTP)… OPEN Failure’

    It then repeats ‘OPEN Failure’ four more times and then it fills the screen with…

    ‘Launch Attempt (xxx) ‘ftp//rapport:r@p8p0r+@xxxxx/Tools/sa/root.i2u’ : File Open ERROR for /root.i2u… Unable to continue’

    I have connected manually using FTP to check the connection and it works fine and i have ensured that the Rapport user has FULL access to the inet folder.

    Any ideas? This has only stopped recently.

    Cheers.
    Darron

    #8669
    AvatarAsif
    Member
    • Total Post: 15
    • Regular Joe
    • ★★

    @Darron wrote:

    Hi,

    When i try to send the latest XPe image from Rapport to a terminal, it reboots begins to PXE boot and connects to the server but stops with the error…

    ‘Searching for Interface…+-(HTTP)… OPEN Failure’

    It then repeats ‘OPEN Failure’ four more times and then it fills the screen with…

    ‘Launch Attempt (xxx) ‘ftp//rapport:r@p8p0r+@xxxxx/Tools/sa/root.i2u’ : File Open ERROR for /root.i2u… Unable to continue’

    I have connected manually using FTP to check the connection and it works fine and i have ensured that the Rapport user has FULL access to the inet folder.

    Any ideas? This has only stopped recently.

    Cheers.
    Darron

    Hi!

    I have seen the above error one and half year back, and resolved it. Try this may it also work for you. Goto ur System DHCP and Add the following server options:

    1. Select DHCP Option 043 Vendor Specific Info and insert the decimal value O (zero) and ADD, then

    2.Select DHCP Option 067 Bootfile Name (Class None)
    STRING = rapportitf.0

    Restart the DHCP Services and then try to image again, hope it will work.

    A line of reply would be valued

    Cheers,

    Asif

    #8670
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Thanks Thinkthin for the hotfixes and to Asif and Annu for the DHCP server suggestions.

    I am not in the office until Monday so cannot test this until then. I will post a response on this as soon as i know.

    thankyou for your help.

    #8672
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    Thats a good sugestion Asif but I think that will force every PXE client (including PC’s) to go to the Rapport server if they do a PXE boot. If you have other PXE services on the network like RIS then this may not work for you well. If Rapport is the only PXE server on the network then no problems.

    #8673
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Asif, Annu,

    The changes made on the DHCP server caused a terminal to not boot (invalid image i believe) – i am installing at a new site so am not going to look into it more – i simply undid those changes which cured the problem.

    We do not use PXE beyond Rapport so it caused no other problems for us.

    Again, i will look into the problem next week when back in the office.

    Cheers
    Darron

    #8685
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Thinkthin,

    I applied the two hotfixes as requested, and have rebooted the server. All seems well however when i go to update the images, the devices are no longer listed in the ‘Select Device’ screen. The devices are listed in device manager (green icon) and are showing PXE boot = yes.

    I will look into it and will post the solution, however please do advise if you know what the cause is.

    Regards
    Darron

    EDIT***
    I have not yet been able to apply an image to my XPe terminals, however if i get an image from a device i have the same problem as first posted with ‘OPEN Failure’.

    It appears that the hot fixes did not resolve this issue and may have caused another one!

    #8686
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    The reason you cant see the image is because the Rapport script that imported the images had the line OS=XPE and it should read OS=XP. Edit the Rapport script that comes with the factory image as above and re-import and all will be well.

    As for the open error message I will have to think about this one, will post something shortly. Also can you open the rapport console and under Configuration manager – Utilities – Dignostic create a new one and look for any errors. Also under Report Manager – Log Reports can you post any errors there?

    Thanks,
    -TT

    #8687
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Thinkthin,

    FYI the ammended script fixed the issue of not being able to select devices. Thanks.

    I look forward to your response re the ‘Open Error’ message.

    Regards
    Darron

    #8688
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Great, can you check out the error logs as well?

    Cheers

    #8689
    AvatarDarron
    Member
    • Total Post: 12
    • Regular Joe
    • ★★

    Thinkthin,

    Sorry, missed that off the last post. The logs are all clear – nothing of any use whatsoever.

    Its weird as nothing has changed since it was installed? (except for the Microsoft critical updates)

    Its certainly a weird one!

    Darron

    #8690
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Darron,

    Can you check the following, from the Rapport console go to Configuration Manager – Software Repositories and right click on Master Repository and select Test Connection. Does this work? Also if the location field there is set as a FQDN change it back to the IP of the Rapport server. If the test connection fails reset the rapport user account password on the server (not in the console) and change the password in the Master Repositiry to match. Also set the local rapport user account password to never expire.

    I will wait for an update,

    Cheers,
    -TT

Viewing 15 posts - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.