DNS Round Robin

  • This topic is empty.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #899
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    I have set up two terminal servers and made and entry in DNS that will round robin the two servers for a cheap-man’s load balancing. I have gotten my HP thin clients to go back and forth between the two. But when I try on the Wyse thin clients, it only goes to one of the servers.

    Is there somewhere that holds on to that address?

    #11535
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    Hi,

    to help you we do need a lot more informations.
    What clients are you using?
    What firmware is installed?
    ICA or RDP?
    Are you using wnos.ini? Please post.

    Cheers
    CG

    #11536
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    Sorry, all are v10l’s.
    Firmware is 5.2.0_35.05 and 6.0.0_14.
    RDP
    Using wnos.ini generated by your software 😀

    Thanks

    #11537
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    Please post your wnos.ini

    #11538
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    Rapportserver=server
    Privilege=HIGH Lockdown=yes HidePPP=yes HidePN=yes HideConnectionManager=yes EnableNetworkTest=yes ShowDisplaySettings=yes EnableKeyboardMouseSettings=yes

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Desktop=thinclientlogo.jpeg
    Screensaver=”20″ LockTerminal=no Type=2 Image=cmklogo.jpeg

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=server timeformat=”12-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT – 06:00′ ManualOverride=yes Daylight=yes

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Device=Ethernet Speed=”Auto”
    SignOn=No
    Community=blahblah
    MaxVNCD=1
    VncPrompt=No

    ;*************************************************************
    ;* RDP *
    ;*************************************************************

    ;


    ;- RDP Session 1 –
    ;- Each line but the last must end with a ‘ ‘ –
    ;



    CONNECT=RDP
    Host=access
    Description=”Desktop”
    Icon=default
    AutoConnect=yes
    Colors=16m
    Fullscreen=yes
    Experience=0
    Domainname=domainname
    LocalCopy=no

    #11539
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    I just opened a new V10L, made sure that the other server was the next in line, and it still didn’t hit the second server in DNS.

    #11541
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    What do you mean by ” the other server was the next in line”?

    CG

    #11542
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    well, i have 2 server set up. RDP010 and RDP011. If I am on the HP, I will log on, and it will go to 010. I log off and log right back on, and it goes to 011. Back and forth, it round robins the logins.

    If I try it from the Wyse and it only goes to 010. No matter what I do, I can reset it to factory defaults and it still goes to 010.

    #11546
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    Well, out of the blue, it started to work…thanks for the help, confgen!

    #11548
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    There will be a local cache life on the DNS resolution, normally a computer will hold the resolved IP for the host for a bit and this is what may have caused it.

    Once the cache is cleared it goes to the DNS server to resolve the name again and the round robin may occur. Remember round robin is not prefect and expect to see more users on one server than the other,

    Cheers,
    -TT

    #11564
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    It doesn’t have to be perfect for us, we have some pretty powerful servers, but not a lot of users on them yet, our company is growing pretty quick, though. If it does become a problem, then we will get a third party product.

    So are you saying that the V10L held on to this local cache life?

    #11565
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    Yes, it does but the default is taken from the DNS server setting.
    You can use this wnos.ini parameter to force an update each time

    DNSTTL=0

    Cheers
    CG

    #11569
    Avatarjchittick
    Member
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    I’m pretty sure the DNS TTL is already at 0, but where do I put that in the wnos file?

    Thanks once again.

    #11575
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    Somewhere.
    The order of parameters is normally not important.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.