DHCP Options & PXE

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #551
    Avatarnic55
    Member
    • Total Post: 3
    • Newbie

    Hi Guys,

    I’ve got my first winterm here (S90) and am slowly learning the ins and outs as we are looking to roll them out to a few customers. After reading through alot of scarce documentation i still don’t seem to be on the right track to getting pxe boot to work (no previous pxe experience either). What DHCP options should i be setting? Currently i have 186 pointing to the WDM server and 015 with a full local domain. Is there anything else i should take into consideration besides the DHCP server? Note WDM and DHCP are on different physical computers.

    My understanding is to load a clean install onto the terminal pxe must be correctly configured and working, after the xpe firmware has been pushed out, i can send applications/updates to the terminal, then grab an image of the terminal back to the WDM server, then push out the configured image to the rest of the terminals, correct?

    Hopefully i’ve got part of it right, any help is greatly appreciated.

    #9982
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Can you tell us a bit more about what is not working? Any error messages?
    Do you have a second PXE server on the net somewhere like SMS, Altiris, RIS, etc…?

    #9983
    Avatarnic55
    Member
    • Total Post: 3
    • Newbie

    Good point, it had totally slipped my mind that the phone system on the same subnet has pxe support, though afaik not yet configured. I’ll physically seperate the two tomorrow to be sure.

    At boot time when it goes looking for pxe info i get:
    “Getting PXE ……….. Not Found”
    “bootDHCP error not found”
    I’ll confirm the exact error when i get to work tomorrow.

    The device also shows up as ‘non-imagable’ in WDM, and any pxe imaging options are greyed out, trying to push a firmware at boot time also doesn’t work. I guess that means it’s not even talking to the wdm for pxe?

    #9985
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Nic55,

    you are right. As long as the system is showing up as “Imageable=No”, it has never ever contacted the WDM server with a PXE request.
    There could 2 main reasons for that:
    – your second PXE is in conflict with WDM
    – (more likely) the DHCP and the client are on a different subnet. If this is true, you have to configure your router to do a DHCP forwarding to the WDM server. This is normaly called IP helper.
    Just think that the client sends out a PXE request which is actually nothing more than a DHCP request with an additional option tag. Each router is forwarding this request to your DHCP server using the IP helper addresses. But now WDM needs to “hear” this request also. So add a second IP helper entry to your router to point to your WDM server.

    ConfGen

    #9987
    Avatarnic55
    Member
    • Total Post: 3
    • Newbie

    Cheers for your help guys, seems it definatley was something on the old network. Now have a seperate network setup just for the winterm and everything seems to run fine 🙂

    … now onto building my own image.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.