Device Check-in Confusion

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #7880
    AvatarMrCentral
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    First off, the environment: a mixed bag of clients (1200le, S10, C10le) running versions from 4.4_79i to 7.1_122, scattered over about 12 subnets. On a separate subnet (where there are no clients), we have a Server running 2003 with WDM 4.9.1, whose IP address is handed out via DHCP tag.

    When devices restart, they check in and show up green. I have check-ins set for every hour and after two missed check-ins they turn red. Only 20-30% of our clients continue to check in for more than a few hours. I’ve looked for common denominators between the clients that check in or don’t, but both groups contain a mixture of hardware types and software versions. The only true common denominator is that the devices that show a value (ourdomain.local) in the Domain column are all red, and the green ones have nothing in that field.

    Since the devices don’t ever get “added” to an AD domain, I assume they’re picking this up from DNS. But why are some registering this information and others are not? Why should the client’s awareness of its DNS domain be correlated with failing to check in, or vice versa?

    Since I’ve been assigning WDM by DHCP tag, I’ve made sure DNS doesn’t have extraneous alias records pointing to the wrong server, and that wnos.ini doesn’t get in the way of the DHCP inform.

    I’m stumped. Any ideas?

    #23933
    ConfGenConfGen
    Keymaster
    • Total Post: 9902
    • Jedi Master
    • ★★★★★★★

    Try adding a DNS alias and DNS SRV record that points to the WDM server.

    CG

    #23939
    AvatarMrCentral
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I can definitely try adding them back in.

    We used to have them pointing to a 2008 server; when we moved WDM to a 2003 server for compatibility with our 1200LEs I changed the alias records to the new 2003 server, just a few days ago in fact. The problem was happening in spite of the correct server being listed, so I took them out to troubleshoot thinking maybe having more than one method for the clients to find it was confusing them somehow.

    Should I try only the DNS aliases without the DHCP tags or manual assignment through wnos.ini? Or is it better to have multiple methods?

    #23940
    ConfGenConfGen
    Keymaster
    • Total Post: 9902
    • Jedi Master
    • ★★★★★★★

    I would recommend nowadays to have DNS SRV record, DNS alias and DHCP option tag configured. No need to put it in the wnos.ini.

    CG

    #23942
    AvatarMrCentral
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Turns out I misremembered deleting those records. I went through and updated them last week. I only deleted them on one subnet to see if it made a difference. So both the CNAME and SRV records are in place and the DHCP tag, but it seems not to be making a difference to the couple clients that have been restarted this afternoon. I’ll wait until tomorrow to see what happens with them overnight.

    ConfGen, do you happen to know how the Domain column in WDM is filled? I’m curious what information is supplied where to determine whether the field is empty or not. It’s not specified anywhere in wnos.ini that this machine is part of domain.local. So I would assume WDM just fills it in from DNS, but then there wouldn’t be any clients missing that field. It just doesn’t make any sense to me.

    #23945
    AvatarMrCentral
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Well, it started appearing that our problem was with DNS—namely that most of our clients were not being registered properly in DNS.

    I found this thread: http://www.freewysemonkeys.com/modules.php?name=Forums&file=viewtopic&t=6433&highlight=dns
    Which helped me fix that problem. I was optimistic that it would solve our check-in failures as well, but I’ve just confirmed that the problem is the same as before, with slightly more detail.

    Clients check in once and then stop. I normally have check-ins set for every hour, but I’ve set them to 30 minutes to speed up the process so I can more easily notice patterns. After restarting the device, the initial check-in occurs. When the hour rolls around, it turns yellow (2 misses results in a yellow icon). After that they start to turn red and never check in until they’re rebooted.

    The only exceptions are the clients which haven’t been restarted since they were registered in DNS. They continue to check in, but as soon as I restart them, they’ll check in once and then stop. I just don’t know what else to try at this point.

    #23967
    ConfGenConfGen
    Keymaster
    • Total Post: 9902
    • Jedi Master
    • ★★★★★★★

    There is a hotfix for WDM available fixing some check-in issues with WTOS. Have you installed that one?

    CG

    #23986
    AvatarMrCentral
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I haven’t, and I doubt I’ll be able to since I don’t believe the company I’m working for has a maintenance contract.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.