Contacting WDM Server…

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
    Posts
  • #6960
    AvatarRoRsChAcH
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    I’m in the process of building our .ini file and I’m trying to have clients connect to our RDS farm if our WDM/FTP server is offline. We are using DHCP option tags 161, 162, 186, and 192. When I take the WDM/FTP server offline our WTOS clients hang at “Contacting WDM server…” for a minute or two before finally connecting to our RDS farm. Is there a way I can speed this process up? Or configure it? Nothing jumped out at me through ConfGen. Thanks!

    #21388
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    This is definetly a problem. Wyse has changed something in the code some month ago and since then we see this big delay when a File- or WDM-server is not available. Nothing to do there beside pushing Wyse to change this.

    CG

    #21396
    AvatarRoRsChAcH
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    👿 😥 Thanks for letting me know!

    #22469
    Avatarmick78
    Member
    • Total Post: 45
    • Frequent Flyer
    • ★★★

    Hi,

    any update with this issue ?

    regards,

    michael

    #22472
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    Should be fixed in latest WDM/Thin OS combination.

    CG

    #22573
    Avatartlap82
    Member
    • Total Post: 5
    • Newbie

    Hello!

    I’m using WDM 4.9.1 and WTOS 7.1_033 on a C10LE and it still takes very long to contact the WDM server. To which WDM/WTOS version are you refering?

    Greeting
    tlap

    #22577
    Avatarphilterx
    Member
    • Total Post: 1
    • Newbie

    Hello!

    I’m using WDM 4.9.1 and WTOS 7.1_033 on a C10LE and it still takes very long to contact the WDM server. To which WDM/WTOS version are you refering?

    Greeting
    tlap

    I am running WDM 4.8.5 and WTOS 7.1_033 on C10LE on a test client and getting the same issue, have not tried it on V10L yet.

    It takes for ever to load 🙁

    DHCP options 161 and 186 have been configured and tried entering DNS and IP values to see any differences; i found none.

    I disabled Firewall and adding exceptions but still no performance gain.

    I was only playing with it for a couple hours so any other ideas you could suggest would be fantastic, for now I will stick with 6.5 and early 7 revisions.

    Cheers,
    Phil

    #22595
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    So you all are still seeing an big delay during boot when the clients try to contact WDM? Even when WDM is online?

    CG

    #22603
    Avatartlap82
    Member
    • Total Post: 5
    • Newbie

    Yea, it still take too long to boot. I’ll let you know if 7.1_127 solved the problem.

    #22647
    Avatarmick78
    Member
    • Total Post: 45
    • Frequent Flyer
    • ★★★

    hi,

    So with the 7.1_127 ?

    regards 🙂

    #22736
    Avatartlap82
    Member
    • Total Post: 5
    • Newbie

    As i wasn’t able to find the problem i reinstalled a new WDM server from scratch, factory reseted the Clients – no change. After we analyzed the traffic with wireshark we found out that the c10le was trying to contact two IPs that look like some sort of failback before it would contact the DHCP-provided WDM Server Adress. We decided to remove the WDM DHCP Option (186 if i remember correctly). This lead us to the following error:


    11:40:34 DNS/WINS can't resolve [wdmserver]
    11:40:34 Looking up WDM server by DNS SRV record ...
    11:40:34 DNS/WINS can't resolve [_wdmserver._tcp.]

    so we created the cname wdmserver.domain.tld (where domain.tld stands for our domain.) – BOOM boot within 9 seconds!
    ❗ Just be carefull as it looks like clients running WTOS <7.122 can't use the DNS Lookup feature.

    At the moment i’m using WDM 4.9.1 workgoup edition (with ftp) and WTOS 7.127.

    #22739
    Avatarmick78
    Member
    • Total Post: 45
    • Frequent Flyer
    • ★★★

    9 sc …

    As for me, when i restart the IIS server, the boot is OK (less 2 sc). but after few time, the boot has a long delay again …

    I think the problem comes from the IIS server/services, but dunno which services…

    #22744
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    Within the new firmware you can modify which lookup mechanism WTOS should use to find the WDM server. It is in the central configuration tab. Disable all that you do not need.

    CG

    #22762
    Avatarbobo8488
    Member
    • Total Post: 4
    • Newbie

    Hi all!
    The message “Contacting WDM Server” takes 16sec. I’ve analized the traffic from the Wyse T10 to the WDM server and there is not traffic for 10 seconds. After 10 seconds there are many messages received from the WDM SERVER and then the login’s menu appear. I don’t know why it takes 16sec to start up. Can you help me?
    Someone have any idea?
    Thanks.

    #22850
    Avatarkarmakoma
    Member
    • Total Post: 73
    • Back Stage Pass
    • ★★★★

    Running 7.1_122 and do not use WDM. Adding the following option in wnos.ini appears to stop client searching for wdm server.

    RapportDisable=yes

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.