Connecting Wyse S10 though Internet DSL to Citrix Pnagent

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #502
    Avatarentelekia
    Member
    • Total Post: 3
    • Newbie

    Hi to everybody: thanks for your help in advance,

    I’m crazy with this problem. I’m trying to connect though Internet DSL connection with my Citrix Access Essentials 2.0 based on Presentation Server 4.5.

    In the remote place, I have one Windows XP Professional and WYSE S10.

    I can connect trough PNAgent from the remote location with WINDOWS XP PRO, not with wyse.

    The FTP Server is in the WINDOWS XP PRO of remote location. I haven’t configured DCHP server options for the moment.

    I’m not using user.ini for the moment, only wnos.ini.

    I have found an interesting ppt about wyse configuration in http://www.freewysemokeys.com. In this ppt, I could read:

    Citrix PS4 has changed the PNagent web site

    In order to configure it you simply need to edit the following fields in C:InetpubwwwrootCitrixPNAgentconfwebinterface.conf

    with the following information. So long the edits are made to the ClientAddressMap that specifies to use SG or not, PN get’s the correct info and it connects fine.

    ClientAddressMap=*,SG
    CSG_Server=fqdn_csg_server
    CSG_ServerPort=443
    CSG_STA_URL1=http://fqdn_sta_server/scripts/ctxsta.dll

    Ok, so I have configured my webinterface.conf in this way:

    OLD WEBINTERFACE CLIENTADDRESSMAP SECTION

    ClientAddressMap=*,Normal
    ClientProxy=*,Auto,-
    # CompanyHomePage= # CompanyLogo=../media/citrix.gif CredentialFormat=All CSG_EnableSessionReliability=Off # CSG_Server=[IP address or FQDN of the Secure Gateway server]
    CSG_ServerPort=443
    # CSG_STA_URL1=

    NEW WEBINTERFACE CLIENTADDRESSMAP SECTION

    ClientAddressMap=*,SG
    ClientProxy=*,Auto,-
    # CompanyHomePage=
    [URL of your company home page] # CompanyLogo=../media/citrix.gif CredentialFormat=All CSG_EnableSessionReliability=Off
    CSG_Server=172.16.11.2
    CSG_ServerPort=443
    CSG_STA_URL1=http://localhost:8001/Scripts/CtxSTA.dll

    Finally, I have configured my wnos.ini:

    #



    # GLOBAL PARAMETERS

    #


    signon=1
    AddCertificate=rootcert.cer
    PnliteServer=https://www.privado.myweb.net
    Seamless=yes
    autoload=1
    language=es
    Resolution=1280×1024 Refresh=75
    ScreenSaver=1 LockTerminal=yes SoftSaver=yes Type=3 Image=screensave.jpg Desktop=Wysepaper.jpg Privilege=high lockdown=no TimeZone=”GMT + 02:00″
    ManualOverride=yes
    TimeServer=212.95.210.35
    VncPrompt=0
    NoticeFile=Notice.txt
    FormURL=Wyse_S10.bmp

    And this is the status log of the WYSE:

    1: System Version: 5.1.028f (ROM: 1.10i)
    2: Ethernet device version: RTL-8100B/8139D.
    3: Checking security key …
    4: Built-in certificate BTCTRoot.crt is installed
    5: Built-in certificate Class3PCA_G2_v2.crt is installed
    6: Built-in certificate Class4PCA_G2_v2.crt is installed
    7: Built-in certificate GTECTGlobalRoot.crt is installed
    8: Built-in certificate GTECTRoot.crt is installed
    9: Built-in certificate Pc32ss_v4.crt is installed
    10: Built-in certificate SecureServer.crt is installed
    11: Built-in certificate EquafaxCA1.crt is installed
    12: Contacting SNTP [212.95.210.35] …
    13: Contacting File Server …
    14: Accessing system profile …
    15: Invalid statement: Image
    16: Invalid statement: ManualOverride
    17: Checking Software ftp:/wnos/RCA_wnos …
    18: SNTP: receive -1, errno: 4
    19: Contacting SNTP [212.95.210.35] …
    20: SNTP: receive -1, errno: 4
    21: Contacting SNTP [212.95.210.35] …
    22: Http open (https://www.privado.myweb.net) = -1, errno = 0

    Cheers,

    #9836
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Thanks for the URL, I am assuming you are setting up the Windows CSG here. I tested the URL and it looks like you are using your own CA. You will need to import the root certificate to the S10 to make this work and also make sure the S10 is set up to get network time correctly. Have a look at the params guide or the PNagent sample configuration in the WTOS downloads section.

    Cheers,
    -TT

    #9844
    Avatarentelekia
    Member
    • Total Post: 3
    • Newbie

    Hi thinkthin again,

    I have resolved all problems about parameters but i’m having the same problem: “time server doesn’t work yet!”.

    the problem is in the ntp server: Wyse look like doesn’t take the configuration from the server.

    Could you help me? i’m lost in this problem: thanks again!

    WNOS FILE

    signon=1 connectionManager=maximize

    autoload=2

    Addcertificate=rootcert.cer

    Resolution=1280×720

    Formurl=logo.bmp

    DefaultUser=gmendez

    PNLiteServer=https://www.privado.myweb.net/Citrix/PNAg

    ent/config.xml

    seamless=yes

    Privilege=high

    TimeZone=”GMT + 01:00″ TimeZoneName=”Romance”

    TimeServer=slug.ctv.es;212.95.210.35;clock.netcetera.dk;clock2.netcetera.dk

    Language=Es

    connect=RDP
    description=”Windows XP pro”
    host=192.168.0.128
    Fullscreen=no
    Colors=High
    NoReducer=no
    autoconnect=0
    LocalCopy=no

    STATUS LOG

    1: System Version: 5.1.028f (ROM: 1.10i)

    2: Ethernet device version: RTL-8100B/8139D.

    3: Checking security key …

    4: Built-in certificate BTCTRoot.crt is installed

    5: Built-in certificate Class3PCA_G2_v2.crt is installed

    6: Built-in certificate Class4PCA_G2_v2.crt is installed

    7: Built-in certificate GTECTGlobalRoot.crt is installed

    8: Built-in certificate GTECTRoot.crt is installed

    9: Built-in certificate Pc32ss_v4.crt is installed

    10: Built-in certificate SecureServer.crt is installed

    11: Built-in certificate EquafaxCA1.crt is installed

    12: Contacting File Server …

    13: Accessing system profile …

    14: Checking Software ftp:/wnos/RCA_wnos …

    15: Contacting SNTP [slug.ctv.es; 212.95.210.35; clock.netcetera.dk] …

    16: SNTP: receive -1, errno: 4

    17: Contacting SNTP [slug.ctv.es; 212.95.210.35; clock.netcetera.dk] …

    18: Http open (https://www.privado.myweb.net/Citrix/PNAgent/config.xml) = -1, errno = 0

    #9845
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Try using this one time server and remove the rest:

    TimeServer=ntp.tpg.com.au

    Does this one work?

    Make sure the ports are open,

    Cheers,
    -TT

    #9851
    Avatarentelekia
    Member
    • Total Post: 3
    • Newbie

    Hi thinkthin, Thanks a lot for your help. Is better than the wyse support! Incredible…

    I have just found the error: Time commands need to be on one line.

    I have installed again the certificate. Only for a one time the certificate was installed on memory Flash. Maybe it´s normal because after the certificate could be on memory. Isn’t it?

    But the problem continues: time server doesn’t work yet!

    Thinkthin, what’s your opinion about changes in webinterface.conf? You can have a look in my first post.

    I have not configured DHCP Server, maybe is it the problem? I don’t think so…

    #


    # global parameters
    #


    signon=1 connectionManager=maximize

    autoload=2
    Addcertificate=certificado.cer

    Resolution=1280×720

    Formurl=logo.bmp

    DefaultUser=gmendez

    PNLiteServer=https://www.privado.myweb.net/Citrix/PNAgent/config.xml

    seamless=yes

    Privilege=high

    TimeZone=”GMT + 01:00″ TimeZoneName=”Romance” TimeServer=slug.ctv.es;212.95.210.35;clock.netcetera.dk; clock2.netcetera.dk

    Language=Es

    #


    # programmable parameters
    #


    connect=RDP
    description=”Windows XP pro”
    host=192.168.0.128
    Fullscreen=no
    Colors=High
    NoReducer=no
    autoconnect=0
    LocalCopy=no

    STATUS LOG

    1: System Version: 5.1.028f (ROM: 1.10i)
    2: Ethernet device version: RTL-8100B/8139D.
    3: Checking security key …
    4: Built-in certificate BTCTRoot.crt is installed
    5: Built-in certificate Class3PCA_G2_v2.crt is installed
    6: Built-in certificate Class4PCA_G2_v2.crt is installed
    7: Built-in certificate GTECTGlobalRoot.crt is installed
    8: Built-in certificate GTECTRoot.crt is installed
    9: Built-in certificate Pc32ss_v4.crt is installed
    10: Built-in certificate SecureServer.crt is installed
    11: Built-in certificate EquafaxCA1.crt is installed
    12: Contacting File Server …
    13: Accessing system profile …
    14: Installed certificate certificado.cer on Flash!
    15: Installed certificate certificado.cer on RAM!
    16: Checking Software ftp:/wnos/RCA_wnos …
    17: Http open (https://www.privado.myweb.net/Citrix/PNAgent/config.xml) = -1, errno = 0

    Cheers,

    #9853
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Did you try one time server? I noticed you have ; in the time servers and this is incorrect you need , between servers.

    The certificate loads once and then stays on flash.

    Once you have the time server running try and log in via CSG and post the results, your webinterface.conf looks OK to me!

    Thanks for the support, we try to help here but it really depends on how busy I am and if I have time to post,

    Cheers,
    -TT

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.