Com port redirection

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #54407
    AvatarJayemm
    Participant
    • Total Post: 5
    • Newbie

    <p style=”text-align: left;”>We have a usb device called a puck that requires a com port to function. Users that have a laptop to connect to the VDI are able to use the device properly. We have enabled and configured serial port redirection within the view agent for this device to work. When the puck is connected to a Wyse box, I can see it in the event log. When a VDI is launched, there was an event stating serial cable detach. That was resolved by turning off the usb redirection in global connection settings. I have configured a force redirection with no luck. I then set it to force local, also no luck. Also turned on serial port mapping in the configuration generator, still no luck. No matter what settings I change, I do not see the device show up in device manager on the VDI.  Any ideas on how to redirect the com port?</p>

    #57088
    AvatarJayemm
    Participant
    • Total Post: 5
    • Newbie

    Found the resolution for this issue.

    Per Dell, this feature is not supported in version 8.6, but does work in the 9.1 release.

    I will be upgrading to this version and testing this.

    #57212
    AvatarTenkrat
    Participant
    • Total Post: 3
    • Newbie

    Hi,

    1.For the non-working scenario, is there RD Gateway role installed?

    If yes, please check CAP via RD Gateway Manager, ensure that Ports redirection is not disabled under Device Redirection tab.

     

    2.Is there any error message when you found the com port redirection failed?

    #57897
    AvatarJayemm
    Participant
    • Total Post: 5
    • Newbie

    Users connect using VMWare Horizon.

    Based on the admin guide, this feature is not supported in version 8.6

    We have since updated a machine for testing to the 9.1 version, which does support this feature.

    What we are running into at this time is the test machine is not connecting properly to the connection broker, we are seeing an error stating broker session timeout.

    Based on the 9.1 release notes, this version has been tested with Horizon 7.12, while the version we have in production is 7.11.

    At this time, we have a Horizon 8 test environment spinning up to test this scenario.

    #58318
    ConfGenConfGen
    Keymaster
    • Total Post: 11288
    • Jedi Master
    • ★★★★★★★

    If you ignore the “Broker timeout” message and leave it untouched, are you able to open your connections?

    CG

    #58566
    AvatarJayemm
    Participant
    • Total Post: 5
    • Newbie

    If we ignore the pop up, yes, we are able to work within the VDI.

    I did have to turn on relative mouse to navigate within the VDI.

    Serial port redirection is working with the new ThinOS version and Horizon 7.11

    #58933
    ConfGenConfGen
    Keymaster
    • Total Post: 11288
    • Jedi Master
    • ★★★★★★★

    I have seen this once now with a customer of mine and wasn’t able to find a solution until now. Please keep us updated about your findings.

    CG

    #58988
    AvatarJayemm
    Participant
    • Total Post: 5
    • Newbie

    The current status is as follows:

    Since version 8.6 does not support serial (or com) port redirection, I upgraded a test box to 9.1.

    Since that upgrade, I am able to connect to our 7.11 Horizon environment, but am getting a pop up stating that there was a broker timeout error.

    As long as this pop is moved as far off screen as possible, and ignored, I am able to interact with the VDI, as long as relative mouse has been turned on, either within the admin policy tool settings, or manually from the pop out menu on the Wyse box toolbar that can be seen when connected to a VDI

    Serial port redirection is currently working properly, and redirection of the USB device has been configured with a GPO, referencing the device by it’s name as seen in the VMWare Serial Port Redirection pop up.

    Once we have found a resolve to the timeout pop up, I will post a reply to this post

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.