Com port mapping S10 in a Citrix Session PS4

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #579
    Avatarsteinlager
    Member
    • Total Post: 20
    • Regular Joe
    • ★★

    I have an S10 trying to do some COM port redirection in Citrix for a serial connected scale device.
    Using the Net use use com1 in a dos window to map a server port to a client (s10) com port.
    This works on a windows PC (same citrix server etc). When the S10 maps the port it appears to work but when the windows application checks the com port it fails.
    The firwmare version on the S10 is 5.2.050.

    Does anyone have any other suggestions…
    There must be something different between Windows mapping a com port and an S10 mapping a com port?
    Does windows provide some other handshaking that the winterm can’t provide?

    Below is the status of the com port after connecting with

    net use com1: \clientcom1:

    Status for device COM1:


    Baud: 9600
    Parity: None
    Data Bits: 8
    Stop Bits: 1
    Timeout: OFF
    XON/XOFF: OFF
    CTS handshaking: ON
    DSR handshaking: OFF
    DSR sensitivity: OFF
    DTR circuit: ON
    RTS circuit: ON

    #10101
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Steinlager,

    Be a while since I have seen you post!

    WTOS is Unix based and there are some slight differences with the way Unix handles the CTS from memory. Now in most occasions this is not an issue and I have used scales with a S10 before.

    However I did have an issue on a Oliveti serial printer that used bi-directional serial printing. In the end we put a break out box on the cable and released WTOS used different pins to windows and made a cable to suit and all was well!

    Before you Google up the Unix serial pin outs, use hyperterminal to a simple serial device like a console port on a switch and make sure you serial port mapping is working.

    Cheers,
    -TT

    http://linux.die.net/man/n/open

    “If type is none then any handshake is switched off. rtscts activates hardware handshake. Hardware handshake signals are described below. For software handshake xonxoff the handshake characters can be redefined with -xchar. An additional hardware handshake dtrdsr is available only under Windows. There is no default handshake configuration, the initial value depends on your operating system settings. The -handshake option cannot be queried.”

    #10109
    Avatarsteinlager
    Member
    • Total Post: 20
    • Regular Joe
    • ★★

    Fantastic, thanks for you reply. This makes sense and gives us something to work with.

    Yes my postings are somwhat eratic, of course i would post more but you guys seem to fix everyones querries so dam fast….:-)

    #10111
    Avatarsteinlager
    Member
    • Total Post: 20
    • Regular Joe
    • ★★

    Well, i have already had feedback from the customer after your repsonse and adjusting the flow control on the terminal and setting it to “none” has already fixed it… they are now starting testing and of course loving it 😉

    I didn’t even get a chance to dust of my soldering iron, damn.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.