Clients not registering in WMS

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #104970
    AvatarMitchvG
    Participant
    • Total Post: 4
    • Newbie

    Hi,

    We’re currently in the process of migrating our Wyse clients from WDM to WMS. Because of the borky state of our WDM, we’ve decided to migrate the machines by resetting them.

    Steps of migrating are:

    1. Configure DHCP options (165,166,167,186,199), with CA validation on false
    2. Reset client (G-key or login and factory reset)
    3. Validate clients in WMS

    Turns out that some clients do register within WMS and some don’t. We’ve checked  DHCP  and the clients do get an address, in turn that means they have the correct firewall rules. What is happening what prevents those clients from connecting?

    #104971
    AvatarChris S
    Participant
    • Total Post: 21
    • Regular Joe
    • ★★

    Hello,

    I’m not sure if this will help but I migrated to WMS a few years ago but I had to turn off  no global ini in the advanced settings then I put this line it the INI of each thin client group and then rebooted the thin clients after changing the DHCP options.

    CCMEnable=yes CCMServer=xx.xxx.xx.xxx:8080 GroupPrefix=defa GroupKey=(group/folder name in wms) MQTTServer=xx.xxx.xx.xxx:1883 AdvancedConfig=yes Override=yes

    I didn’t reset them like your doing. Also WMS didn’t have the Enrollment Validation when I migrated. You could try turning it off  and see if that helps at least until you get everything moved.

    #104972
    AvatarMitchvG
    Participant
    • Total Post: 4
    • Newbie

    I’m aware of that config. We currently run an environment which has multiple thin os versions (how, don’t ask.. inherited environment). Different thin os versions handle a migration INI differently in our experience..

    We opted to go for resetting the machines instead, which allows us to start ‘fresh’.

    #104990
    ConfGenConfGen
    Keymaster
    • Total Post: 11287
    • Jedi Master
    • ★★★★★★★

    Do you see a similarity that checked-in devices maybe have a higher firmware version?
    The client should run a minimum of 8.3 firmware.

    CG

    #105009
    AvatarMitchvG
    Participant
    • Total Post: 4
    • Newbie

    The vast majority of the clients are running 8.3+. From what I can see is that my predecessor has made two images, one with 8.4 and 8.5. That said, for some reason we still have ~30 clients which run version 8.2, which isn’t configured as far as I can tell.

    For testing I’ve requested one of the ‘faulty’ devices, which happens to be one of the clients which  runs 8.2. Other devices which show the problem run 8.3.

    #105081
    ConfGenConfGen
    Keymaster
    • Total Post: 11287
    • Jedi Master
    • ★★★★★★★

    As already said, 8.3 is the absolute minimum. You should go to the latest available one if possible.

    CG

    #105090
    AvatarMitchvG
    Participant
    • Total Post: 4
    • Newbie

    We have found the issue. It was a combination of <8.3 (as you replied), with an oversight in the DHCP scope options.

    We’ve added options 165 and 166 as “wms.test.lan”, while some clients expect “wms.test.lan:443” and “wms.test.lan:1883” respectively.

    Cheers!

    • This reply was modified 1 month ago by AvatarMitchvG.
Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.