Cant get Password ‘change at first log on’ to work on wtos

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #7046
    Avatarsaston
    Member
    • Total Post: 32
    • Frequent Flyer
    • ★★★

    I am using Xendesktop 5.5 / WTOS 7.0_113.

    I have a log on box on the Wyse terminal with username, password and domain.

    If the user account in Active Directory has the tick box for ‘change password at next log in’ ticked they cannot log in. They get ‘Citrix sign-on failed’. If the tick box is cleared then the user can log in.

    I would like it so that the user CAN change the AD password at the Wyse log in screen.

    #21584
    Avatarjamesjhughes
    Participant
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi,

    Do you use Citrix Web Interface? Try this

    http://www.freewysemonkeys.com/products/1000/Password_change_in_a_Citrix_environment.pdf

    Regards

    James

    #21595
    Avatarsaston
    Member
    • Total Post: 32
    • Frequent Flyer
    • ★★★

    Thanks for your reply.

    I tried that this morning but it seems have had no effect.

    If the ‘change password at next log in’ is ticked on the users account then you cannot get past the wtos log on screen. As soon as you take the tick off the user can log in fine.

    #21597
    ConfGenConfGen
    Keymaster
    • Total Post: 11113
    • Jedi Master
    • ★★★★★★★

    Post your wnos.ini please.

    The above mentioned PDF does fix it 100%.

    CG

    #21598
    Avatarsaston
    Member
    • Total Post: 32
    • Frequent Flyer
    • ★★★

    autoload=1

    FormURL=nsclogosmall.jpg

    DomainList=”VDI”

    NoticeFile=Legal.txt Resizable=yes

    signon=1 ConnectionManager=Maximize EnableOK=yes

    TimeZone=’Greenwich Mean Time’ ManualOverride=yes

    Autosignoff=yes Reboot=yes

    Desktop=wallpaper.jpg

    Language=Uk

    PNliteServer=https://psp.vdi.local ReconnectAtLogon=2

    PRIVILEGE=High

    SessionConfig=all Smartcards=yes

    #21602
    Avatarsaston
    Member
    • Total Post: 32
    • Frequent Flyer
    • ★★★

    Dear ConfGen

    Please can you have a look at my wnos.ini file settings above?

    Many thanks.

    #21608
    ConfGenConfGen
    Keymaster
    • Total Post: 11113
    • Jedi Master
    • ★★★★★★★

    The wnos.ini looks very good. So no indication that this is the root cause.
    Now we are back to your PNagent site.
    Please make sure that you did the modifications as mentioned in the PDF on the correct site. Not the webinterface but PNAgent site!

    CG

    #21613
    Avatarsaston
    Member
    • Total Post: 32
    • Frequent Flyer
    • ★★★

    Thanks.

    Now I know it is not the wnos.ini it must be something else.

    I have definitely 100% set the setting on the Xenapp services site as per the document but it still does not work (unless I am doing something competely stupid I am missing).

    The Xenapp Sevices site is for XenDesktop 5.5 access and is on a Citrix Secure Gateway server and is connected via https. Could this be having an effect?

    Could I just clarify something: if this works as it should then the user should get an additional pop up box on the Wyse terminal sign on page asking them to set the password? I am expecting the user to have a password change popping up actually on the Wyse terminal sign on screen, right?

    #21614
    ConfGenConfGen
    Keymaster
    • Total Post: 11113
    • Jedi Master
    • ★★★★★★★

    Your expectation is correct.

    CG

    #21616
    Avatarsaston
    Member
    • Total Post: 32
    • Frequent Flyer
    • ★★★

    Ok – I will have to keep working on it then if you are 100% it does work in the scenario I have described.

    Thanks.

    #21618
    ConfGenConfGen
    Keymaster
    • Total Post: 11113
    • Jedi Master
    • ★★★★★★★

    Can you try to change or create a PNAgent site without SSL? I doubt that this is the issue, but worth a try.

    CG

    #21717
    AvatarAmerist
    Participant
    • Total Post: 61
    • Back Stage Pass
    • ★★★★

    Here’s what worked for us:

    Signon=NTLM DisableGuest=yes

    find any other

    signon=

    in the INI file and remove it.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.