C50LE not applying settings in $MAC.ini

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7170
    NENPL
    Participant
    • Total Post: 18
    • Regular Joe
    • ★★

    C50LE 11.1.053, reset to factory default

    I am trying to use $MAC.ini files to configure my C50LEs but the settings in the file do not get applied to the thin client. If I open the “Diagnostics” application, the contents of the $MAC.ini file appears under “wlx.ini/wnos.ini”, so the thin clients can definitely read the file. I am confident the INI files are formatted properly because if I rename the $MAC.ini file to “wlx.ini”, the settings in the file are applied properly.

    Has anyone else had this problem?

    #21925
    NENPL
    Participant
    • Total Post: 18
    • Regular Joe
    • ★★

    I found the problem. Looking through the INI Ref Guide, I found a reference to “include=$mac.ini“. The documentation states that this line should be added wlx.ini file, to have it include parameters from the $mac.ini. But the documentation also states that “If the thin client locates a $MAC.ini file (it is stored in the same directory as a wlx.ini file), then the wlx.ini file is not accessed.” So in cases where the $mac.ini file is the only file being accessed, you have to add “include=$mac.ini” to the beginning of the $mac.ini file.

    So now my question is, how do you format the path in the “include” statements, so you can store the $mac.ini in another directory? The documentation defines the include parameter as “Include=path/filename”, so it should be possible. I would like to store the $mac.ini files in a subdirectory:
    /wyse/wlx/inc/$mac.ini
    I have tried:
    include=/wyse/wlx/inc/$mac.ini
    include=wyse/wlx/inc/$mac.ini
    include=/wlx/inc/$mac.ini
    include=wlx/inc/$mac.ini
    include= /inc/$mac.ini
    include= inc/$mac.ini
    The file and folder have the same permissions as the /wyse/wlx/wlx.ini file, which reads in fine.
    Any ideas?

    #21927
    NENPL
    Participant
    • Total Post: 18
    • Regular Joe
    • ★★

    I have a work around, but it is not pretty. I put the $mac.ini files in the same directory as the wlx.ini file. The first two lines of the $mac.ini files are:
    include=wlx.ini
    Include=$mac.ini

    I found if I put anything before them, even a comment, it does not work. To my mind, this should cause a loop, but it seems to work. If anyone has a better way of doing this, please let post back.

    #21934
    NENPL
    Participant
    • Total Post: 18
    • Regular Joe
    • ★★

    I was mistaken. Short version, the first line of the $mac.ini file must be Include=$mac.ini

    I thought the thin client read would read in any include statement it found in the $mac.ini file. It will, but only if the first line of the $mac.ini file is Include=$mac.ini. This seems to contradict the documentation which states, “NOTE: Only one level of include is allowed (nesting is not allowed).” Since the opening Include=$mac.ini seems to instruct it to used the rest of the file, which has another include statement.

    As far as I can tell, the entire $mac.ini file implementation for the C50LE, and I imagine all of the Wyse enhanced SUSE Linux thin clients, is fubar. One has only to see how simply and easily it works with the ThinOS thin clients, to see how poorly it is implemented on the Wyse enhanced SUSE Linux thin clients.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.