admin.ini file

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #294
    AvatarWysenewbie69
    Member
    • Total Post: 8
    • Newbie

    I have my wlx folder with a wlx file. Inside this i have an ini folder and a file called admin.ini in there so it picks up my main wlx file great. but if i choose to sigh off from this account because i need to login as admin it wont recognise my admin account. My question is in my admin.ini files do i have to specify a username and password for this account i think the thin client does not know what admin is. I only have the 2 boxes i have disabled the domain box.

    Any suggestions

    Thanks

    #9115
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Yes, correct. If you are not using AD or PNagent you should signon as admin and create a password. This password will be written to the admin.ini file (not in clear text and make sure you can write to the ftp server while this happens.

    After this you can then log in with the admin/password and set the ftp server back to read only.

    The Blazer admin guide on Wyse.com has this process and I assume the Linux guide as well (I have not checked).

    Its a bit strange but for sites with a few terminals it works OK,

    Cheers,
    -TT

    #9120
    AvatarWysenewbie69
    Member
    • Total Post: 8
    • Newbie

    ThinkThin
    So can you break it down a bit do ihave to manually put the username and password in the admin.ini file. Also when i said i had 2 boxes i meant when logging in i disabled the domain box. I have about 20 Thin Clients in all but my first 7 are using touch screen for a specific job so there the ones i am deploying now.

    Thanks
    John

    #9122
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi John,

    Sorry, that’s the problem with forums – so little time to write a decent explanation 🙂

    OK, for a standalone terminal with authentication do the following:

    – set up a ftp server with write access and create a user.ini file for all the users you want to log in, don’t put anything in the file

    – in the wlx.ini enter signon=1

    – boot the terminal and enter a username that corresponds to a user.ini and a password

    – at this time a password will be created in an encrypted format in the user.ini file

    And that’s about it, you can auto login the terminal with a pass through account to avoid normal users entering a username password.

    I hope that helps, if you use Citrix or AD you can avoid all the passwords in files stuff,

    Cheers,
    -TT

    #9124
    AvatarWysenewbie69
    Member
    • Total Post: 8
    • Newbie

    hi still not working here is my setup

    Fileserver=172.17.12.120
    Rootpath=/wyse
    autoload=2
    Autopower=yes
    DesktopTaskbar=Bottom
    EnableLocal=yes
    signon=1
    autologin=yes
    countdown=1
    defaultuser=guest
    defaultpassword=guest
    Privilege=none Lockdown=no
    Bootorder=HNN
    disabledomain=yes

    wyse/wlx folder wlx file in there i have a ini folder and in the ini folder i have admin.ini blank i boot the s50 up logon as guest then logoff and type admin in how s that
    Cheers John

    #15960
    Avatarnot_very_wyse
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Hi,

    I’m also trying to set up an admin.ini account to log on to the V50L. However it doesn’t seem to work properly.

    In my admin.ini file i have set the privilege=high and lockdown=no, i can login with admin access. However, it doesn’t matter what password i entered (even if its blank) i can still login as an admin.

    When i check the admin.ini file, i don’t see any encrypted password.

    The same goes for other user.ini accounts, the privilege is correct when logging on as that user but the password can be blank and it will still work.

    Can you please tell me what is missing /wrong and step me through to get this fix?

    Thanks so much 😀

    #15961
    ConfGenConfGen
    Keymaster
    • Total Post: 9890
    • Jedi Master
    • ★★★★★★★

    What firmware version are you running?

    CG

    #15971
    Avatarnot_very_wyse
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I’m running Version 6.5.2_02
    on BIOS 1.18

    thanks,
    not_very_wyse

    #16540
    AvatarWL
    Member
    • Total Post: 4
    • Newbie

    I have the same problem. But following the above I didn’t get the device to write it’s password hash to the user.ini file. Also I’m not to fond to keep the FTP server write enabled 🙄

    Well, anyway, I was thinking, is it possible to add these hashes manually?

    I noticed on the device that in /var/log/runx.log it states the users password hash. If this is the same as the one needed in user.ini, then it’s as good as done 😀

    All I need to know is syntax. What does it look like when it has worked? Is it a string like:
    PassWord=”blablablarandomstuff” ??

    If someone is kind enough to copy paste this (anonymized) string here as an example, that would be great!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.