Adding printer through wlx.ini

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #432
    AvatarFlip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    I’m trying to add a printer using wlx.ini, these are the lines I add to wlx.ini

    #printer
    Printer=LPD
    Host=192.168.1.40
    Queue=lp

    But no printers appear in the control panel/printers …

    #9599
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Flip,

    Dont forget the PrinterID as this must contain the Windows driver name exactly. Use the Confgen tool to generate the printer configs,

    Cheers,
    -TT

    #9601
    AvatarFlip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    I would like to use the default value :

    Defines a remote Unix LPD printer. Printer
    specifies the name of the printer and is required. If
    the ModelID is not specified, the default
    Generic/Text Only is used. If Enabled is not
    specified, the default is to enable the printer
    (Default = yes). If EnableLPD is not specified, the
    LPD service will not be enabled (Default = yes).
    NOTE: The parameters must be specified in the
    order shown. Be sure not to leave spaces in
    unnecessary places as they may produce
    problems to users.

    Do I need to mention Generic/Text Only as ModelID ?

    #9603
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    If you are using it under RDP/ICA set up the ID as the Windows print driver name like this – “HP LaserJet 4M”

    #9607
    AvatarFlip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    We are using the printer mainly to print screens from out TEC sessions, if I add the printer manually I add the printer as Generic/Text Only, I do not use a winows print driver.

    #9608
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Cool, just use Generic Text for your TEC.

    For local FireFox add the GhostScript.pak and select PCL as the print driver.

    🙂

    #9610
    AvatarFlip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    @thinkthin wrote:

    Cool, just use Generic Text for your TEC.

    For local FireFox add the GhostScript.pak and select PCL as the print driver.

    🙂

    It works fine when I add the printer manually, but I would like to add the printer through .ini files !

    #9640
    Avataranjoha
    Member
    • Total Post: 6
    • Newbie

    😆 Hi

    I,ve tried to use conf gen to generate a wlx.ini file that mapps network printers automaticly.
    This is settings that conf gen makes:

    JetDirectPrinter=10.230.220.207 Name=”SHARP MX-3501N PS” ModelID=”SHARP MX-3501N PS” Enabled=yes EnabledLPD=yes

    But when I boot the Wyse V50L no printers are shown. I’m sure that the wyse have contact with the ftp server because all other settings are ok.

    Thanks for help.

    #9642
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    That’s weird as I tried this config in my lab and a printer is created locally!

    I am not sure what the next step is – maybe try a LPD or SMB printer to see if the creates,

    Cheers
    -TT

    #9644
    Avataranjoha
    Member
    • Total Post: 6
    • Newbie

    What kind of FW are you using on your V50l? Maybe it could be something with the FW and ini settings? Another question about this is does the printer have to be online? We are now in a test phase and don’t at the time have access to any printers on lan that use default printer port (9001)

    My FW revision is: wy_sc_6.3.1-41.64m

    AJ

    #9646
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    That FW should work. No the printer can be off line as all I would expect to see is the printer defined in the Printers applet in the control panel.

    Unfortunately I am on holidays and can not get to a device for a while to test again – sorry 🙁

    -TT

    (Well, OK, its not that unfortunate that I am on holidays for a week!)

    #14460
    AvatarJiggySmack
    Member
    • Total Post: 6
    • Newbie

    I’m trying to add a jetdirect printer on my V50L using the ConfGen app.

    This is what’s added to the wlx.ini file.:

    ;*************************************************************
    ;* Printing *
    ;*************************************************************
    JetDirectPrinter=10.127.1.43 Name=”laser” ModelID=”HP Laserjet 4050″ Enabled=yes EnabledLPD=yes

    Still, no printers show up in my “printers” after the system boots up.

    HELP!

    #14463
    ConfGenConfGen
    Keymaster
    • Total Post: 9890
    • Jedi Master
    • ★★★★★★★

    What firmware are you using?

    CG

    #14464
    AvatarJiggySmack
    Member
    • Total Post: 6
    • Newbie

    My FM is 6.4.0

    Build 19

    #14468
    ConfGenConfGen
    Keymaster
    • Total Post: 9890
    • Jedi Master
    • ★★★★★★★

    Try the latest 6.5.2_02

    CG

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.