AD Group ini

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #41412
    garyc
    Participant
    • Total Post: 4
    • Newbie

    Hi,
    My question revolves around this link:
    http://www.technicalhelp.de/2015/06/21/ad-group-ini/

    I have created the groups and set SignOn=NTLM AdGroupPrefix=xxxxxxxxx in the wnos.ini

    I have the group name ini files in the adgroup folder, but when a user who is in one of these groups logs on, it doesn’t auto connect, I can’t have AutoConnect=xxxxxx in the wnos as this will default for any users that logon

    What needs to be specified in the ad group name.ini ? does it need to have autoconnect=xxxxxxx in there?
    does it need and exit=yes similar to mac.ini files?

    Thanks,
    G

    #41413
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    Please post both INI files, wnos.ini and one adgroup.ini.

    CG

    #41414
    garyc
    Participant
    • Total Post: 4
    • Newbie

    wnos looks like this:

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 6.4.012 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* http://www.technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    ; If you are using a version of WTOS code < 7.1_133 please use:
    ; Rapportserver= instead of WDMServer=
    WDMServer=”https://xxxxxxxx&#8221; Retry=2

    AdminMode=yes Admin-Username=ONALOCAGMHAPMDAI Admin-Password=ONALOCAGMHAPMDAIONHJOOHI
    Privilege=None

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    FormURL=newban.gif
    MirrorFileServer=yes

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    AutoSignoff=yes
    AddCertificate=rootca.cer
    FixLicense=clean
    SysMode=VDI toolbardisable=yes

    ;*************************************************************
    ;* Peripherals *
    ;*************************************************************

    Language=Uk ImageSuffix=gb
    LanguageBar=yes Language=Uk
    KeySequence=yes Ctrl+Alt+Down=no

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    ; If you are using a version of WTOS code < 7.0.1_13 please use:
    ; Resolution=DDC Refresh=
    Screen=1 Resolution=DDC
    Screen=2 Resolution=DDC
    Desktop=WDM_Test.jpg Layout=Stretch
    Screensaver=5 LockTerminal=no Type=2 Image=wyse.jpg

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=10.31.34.1 Timeformat=”24-hour format” Dateformat=dd/mm/yyyy
    ; If you are using an older version of WTOS code please use:
    ; TimeZone= ‘GMT’ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=GMT DayLightName=GMT

    TimeZone=’Greenwich Mean Time’ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=”GMT Standard Time” DayLightName=”GMT Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Terminalname=xxxxx&Right($MAC,6)
    SignOn=NTLM AdGroupPrefix=”AD-TEST-GROUP-“ MaxConnect=1000
    DisableDomain=yes
    DomainList=”xxxxxx”
    PasswordServer=xxxxxxxx
    MaxVNCD=1
    VncPassword=”PCCOPIDI” Encrypt=yes
    VncPrompt=Yes Accept=5 ActiveVisible=yes

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL MapDisks=yes
    Reconnect=yes, 2
    UniSession=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    IcaBrowsing=HTTP
    Seamless=yes
    PnliteServer=https://xxxxxxxxx ReconnectAtLogon=2
    MultiFarm=yes
    SessionConfig=ICA AudioQuality=High

    ;*************************************************************
    ;* General 2 Special *
    ;*************************************************************

    Include=$mac.ini

    ;*************************************************************
    ;* Troubleshooting *
    ;*************************************************************

    adgroup.ini is like this:

    AutoConnectList=”XA Desktop”
    Exit=yes

    #41415
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    AutoConnectList is an optional parameter of the PNLiteServer parameter. You cannot use this one as a standalone one.

    CG

    #41416
    garyc
    Participant
    • Total Post: 4
    • Newbie

    Ok thanks for that, I’m just testing various options, trying to make progress
    so what should the exact syntax be in the adgroup.ini?
    does the autoconnect list overrule anything that is in the adgroup.ini?

    G

    #41417
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    As AutoconnectList is an optional PnLiteServer parameter and PnLiteServer cannot be used in a username.ini or adgroup.ini, there is no way to achieve what you want.

    CG

    #41418
    garyc
    Participant
    • Total Post: 4
    • Newbie

    OK, thanks,
    so what goes in the adgroup ini? is there any other way of linking AD group membership to a particular desktop?

    If I have 3 desktops specified in the AutoConnectList for example, and the logging on user only has one assigned to them, will it connect them without issue?

    Thanks,
    G

    #41419
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    Yes, that will work.
    If only one desktop is assigned to an user, this desktop will always autolaunch, even without AutoConnectList.

    CG

    #41690
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    Hi, I have to take back parts my answer.
    I have tested this today and using pnliteserver in a username.ini IS working perfectly fine.
    Here is what I did:
    – entered pnliteserver=server1 in my wnos.ini
    – created a user1.ini in wnos\ini folder
    – added pnliterserver=server2 in the user1.ini
    – started the ThinOS unit and verified that “server1” is used
    – logged in a user1 and verified that “server2” was used.

    That means that you can add “pnliteserver=your_server autoconnectlist=user1-desktop” to your username.ini.

    That was working perfectly fine with several 8.x firmware versions.

    CG

    • This reply was modified 5 years, 9 months ago by ConfGen.
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.