3150 – PXE Boot, tftpd32 incl DHCP but get static IP 0.0.0.8

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1879
    Cromatic
    Member
    • Total Post: 4
    • Newbie

    Hi everybody,

    wants to install ubuntu server on an USB HDD. I have searched the web for a guide, to establish a Netboot/PXE incl. DHCP Server using Windows.
    But when i start the 3150 i get everytime the 0.0.0.8 Client IP Adress. Mask and DHCP IP are the ones entered in Windows Server Settings.

    My question is, why i get this 0.0.0.8 IP and how can i change it?

    Thanks in advance
    Cromatic

    #15155
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    Where/when do you get this IP? While PXE or in your booted Ubuntu?

    CG

    #15156
    Cromatic
    Member
    • Total Post: 4
    • Newbie

    The IP is shown at boot up sequence on the 3150. I get this output in the Server log:

    Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:13:8F:5E:6E:EA [13/02 16:59:30.906]
    Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:80:64:39:AD:38 [13/02 16:59:50.671]
    00:80:64:39:AD:38: statically assigned to address 0.0.0.8 [13/02 16:59:50.671]
    1384 Request 2 not processed [13/02 16:59:50.734]
    Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:80:64:39:AD:38 [13/02 16:59:52.671]
    Connection received from 0.0.0.8 on port 2070 [13/02 16:59:52.671]
    Read request for file . Mode octet [13/02 16:59:52.671]
    OACK: [13/02 16:59:52.671]
    Using local port 3997 [13/02 16:59:52.671]
    1384 Request 2 not processed [13/02 16:59:52.734]
    Connection received from 0.0.0.8 on port 2071 [13/02 16:59:54.734]
    Read request for file . Mode octet [13/02 16:59:54.734]
    OACK: [13/02 16:59:54.734]
    Using local port 4002 [13/02 16:59:54.734]
    Connection received from 0.0.0.8 on port 2072 [13/02 16:59:58.703]
    Read request for file . Mode octet [13/02 16:59:58.703]
    OACK: [13/02 16:59:58.703]
    Using local port 4011 [13/02 16:59:58.703]
    Connection received from 0.0.0.8 on port 2073 [13/02 17:00:04.703]
    Read request for file . Mode octet [13/02 17:00:04.703]
    OACK: [13/02 17:00:04.703]
    Using local port 4024 [13/02 17:00:04.703]
    TIMEOUT waiting for Ack block #0 [13/02 17:00:07.796]
    TIMEOUT waiting for Ack block #0 [13/02 17:00:09.796]
    Connection received from 0.0.0.8 on port 2074 [13/02 17:00:12.656]
    Read request for file . Mode octet [13/02 17:00:12.656]
    OACK: [13/02 17:00:12.656]
    Using local port 4041 [13/02 17:00:12.656]
    TIMEOUT waiting for Ack block #0 [13/02 17:00:13.765]
    TIMEOUT waiting for Ack block #0 [13/02 17:00:19.765]
    Connection received from 0.0.0.8 on port 2075 [13/02 17:00:22.609]
    Read request for file . Mode octet [13/02 17:00:22.609]
    OACK: [13/02 17:00:22.609]
    Using local port 4068 [13/02 17:00:22.609]
    TIMEOUT waiting for Ack block #0 [13/02 17:00:27.718]
    TIMEOUT waiting for Ack block #0 [13/02 17:00:37.671]
    Connection received from 0.0.0.8 on port 2076 [13/02 17:00:58.671]
    Read request for file . Mode octet [13/02 17:00:58.671]
    OACK: [13/02 17:00:58.671]
    Using local port 4212 [13/02 17:00:58.671]
    TIMEOUT waiting for Ack block #0 [13/02 17:01:13.718]
    Connection received from 0.0.0.8 on port 2077 [13/02 17:02:10.687]
    Read request for file . Mode octet [13/02 17:02:10.687]
    OACK: [13/02 17:02:10.687]
    Using local port 4361 [13/02 17:02:10.687]
    TIMEOUT waiting for Ack block #0 [13/02 17:02:25.734]

    No Ubuntu is booting!

    #15157
    thinkthin
    Member
    • Total Post: 1686
    • Jacked into The Matrix
    • ★★★★★★

    looks like an error from your PXE server – is it on the same box as the DHCP server? Have to user option tag 66 or 67 – what are they set to? Is there any other servers that could be responding to the PXE req.

    Cheers,
    -TT

    #15159
    Cromatic
    Member
    • Total Post: 4
    • Newbie

    Yes, it seems to be a problem with the server. I am now configuring a Linux to be a PXE Server and voila, i works. Why it isn’t working with windows tftpd32 server, i don’t know.

    Thanks to all.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.