WDM 5 HTTP repository errors

This topic contains 2 replies, has 0 voices, and was last updated by  BlueCheesyBard 49 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #8291

    • Total Post: 3
    • Newbie

    I’ve recently installed WDM 5.0 (workgroup) from scratch.

    We are running it on windows server 2012 R2 64bit.

    I’ve never used WDM before, and so apologies if I dont use the right terminology, or I make some basic mistakes.

    When I try to configure the HTTP repository, I get an error. The only situation when I dont get an error is when I tick the ‘read only’ box.

    The error is:-

    [Error:Not Available] [WebDAV error:Failed to upload buffer. HTTP Response Code: 401Remote File Path: {longfilename}.tmp Error Code: 401]

    CIFS and FTP are both fine.

    I’ve checked through the release notes, and cant find anything relating to scripts that have to be run following the completion of the installation, although I know they were needed in previous versions.

    I have tried using HTTP/HTTPS, also local accounts, service accounts, and also a Domain Admin account. All accounts have been set up as local administrators. I’ve now enabled anonymous, basic and integrated authentication.

    I’ve checked within the IIS roles, and from what I can see, all the necessary settings are there, and the adverse settings were not set.

    I’ve removed and recreated the ‘MyWDM’ virtual directory.

    I’ve been gradually opening up security in the ftproot folder until it is now set up Everybody/full access.

    I can browse to it internally on, and externally to, the server.

    The only indication of an error outside the application is that whatever account I use shows up an ‘unknown username or bad password’ event in the security eventlog. This makes me wonder whether or not the system can use NTLMv2 authentication, which is required in my company. The only caveat to this is that CIFS and FTP connectivity work without problems, so I dont think this is likely a problem. Also, I see the problem even using a local account.

    I have not yet set up the pcoip-tool srv record yet, but I’m sure this wouldnt be a problem.

    Can anybody help me with this one? I’ve been bashing my head against the proverbial wall for a couple of days now…


    • Total Post: 3
    • Newbie


    I got temporary dispensation to disable the requirement for NTLMv2 on the server, and the system is now able to authenticate OK using local accounts for CIFS and HTTP. Strangely enough, the FTP repository is still working fine using a domain service account.

    It seems that the 3 repository access mechanisms use totally separate authentication functionality.


    • Total Post: 4
    • Newbie

    I had the same error on Server 2012 and couldn’t find the problem. Good job on that find! I had to revert to a 2008 server and start all over again.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.