Configuration unavaible with DHCP

This topic contains 17 replies, has 2 voices, and was last updated by ConfGen ConfGen 1 month, 1 week ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #45308

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Hello all,

     

    I have an issue with my Wyse when it’s configured with DHCP. In fact, this is working correctly when it’s configured with static IP but when I switch my options to DHCP I have some configurations which become unavaible (grey).

    So when i’m in DHCP Configuration, the terminal does not up to the WDM and I can’t manage it.

     

    Screen in STATIC IP :

    Screen in DHCP :

    Can someone help me please ? Thanks.

     

    System version : 8.0_210

    WDM version : WDM 5.7.2

    Wyse : T0

    #45310
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    Check your DHCP server.
    You are pushing out option tag 186 to the clients and missing option tag 190.

    CG

    #45316

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    This configuration is not correct ?

    #45320
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    OK, you are pushing OT 161 to point the client to a wnos.ini.
    Do you have a WDM server configured in your wnos.ini?

    CG

    #45336

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Yes, but I already use MAC.ini configuration fils in my ftproot/inc/ folder :

     

    MY WNOS.INI :

    MY MAC.INI :

    Is that correctly configured ?

    #45338
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    1. You are pushing out the WDMServer parameter. Therefore, the value is greyed out in the local client. So works as designed.
    2. If you are working with wnos.ini and mac.ini, I would make sure that you only put parameters in the mac.ini that either are not present in the wnos.ini or have to be different.
    Copying the full content of the wnos.ini and just alter some settings makes it difficult to troubleshoot.

    CG

    #45346

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    So if I understand, I need to put generic parameters in the wnos.ini and just the specific parameters of the client in the mac.ini ? (To have a clean configuration).

    SO, In fact, as you notice, the wnos.ini and mac.ini have the same parameters, I tested with a terminal to delete the mac.ini and it work fine without.

    I will delete all the mac.ini and test back.

     

    #45347

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    I work only with the wnos.ini file now but it’s already the bad configuration.

     

    You sayed, “the value is greyed out in the local client. So works as designed.”, but I have my…

    – WDMService=yes
    – WDMServer=”https://192.168.0.214″

    …parameters in the wnos.ini, but the client doesn’t take this parameters. Maybe the terminal check another wnos.ini in an other folder ?

     

    My wnos.ini :

    #45353
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    Can you try “WDMserver=https://192.168.0.214:443”?

    CG

    #45361

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Same issue, I don’t know where it’s taken the WDMServer parameters.

    I can try to write “https” or “http” or “:443”, I always have “WDM agent : open 192.168.0.214 failed”, like this is not applying the changes in the .ini or parameter taken from another place.

    I tried to edit the parameter in the WNOS and the MAC but not changing anyway.

    #45367
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    What happens if you use any other value? Is that shown in the clients config?
    Like WDMserver=1.1.1.1

    CG

    #45373

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    I just tried, same issue. I even try to remove the lines :

    – WDMService=yes

    – WDMServer=”x.x.x.x”

    And I already have the WDM agent : open “192.168.0.2014” failed , like this is not taking the new configuration. Reboot the wyse is that sufficient to apply the new configuration or I need to do another thing ?

    • This reply was modified 1 month, 2 weeks ago by  Beko2.
    #45375
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    Then it really looks like the clients get this info from somewhere else.
    – Check your DNS server if there is an Alias entry with “wdmserver” pointing to the FQDN of your WDM server.
    – Check locally at the client under System Tools. There is one or more tab(s) which show the loaded INI file(s). Any WDM entries there?

    CG

    #45378

    Beko2
    Participant
    • Total Post: 10
    • Regular Joe
    • ★★

    Correct, the configuration is taken by the client as we can see from de System Tools / Global Ini :

     

    But as we say, it’s look like the client is taking it’s WDM parameters from somewhere else.

     

    I checked my DNS and I have :

    And in the reverse DNS

     

    #45392
    ConfGen
    ConfGen
    Keymaster
    • Total Post: 7746
    • Jedi Master
    • ★★★★★★★

    Even after changing the IP to 1.1.1.1, you still do see something different under System Setup – Central Configuration ?

    CG

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.