Index
  Random Headlines
  Who's Online
There are currently, 121 guest(s) and 0 member(s) that are online.

You are an Anonymous user. You can register for free by clicking here
Technicalhelp and Freewysemonkeys: Forums

Technicalhelp and Freewysemonkeys :: View topic - USB Redirection with XenDesktop 5.5 File Access
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

USB Redirection with XenDesktop 5.5 File Access

 
Post new topic   Reply to topic    Technicalhelp and Freewysemonkeys Forum Index -> Wyse Xenith
View previous topic :: View next topic  
Author Message
waspy
Newbie
Newbie


Joined: Jun 07, 2012
Posts: 2

PostPosted: Thu Jun 14, 2012 1:26 pm    Post subject: USB Redirection with XenDesktop 5.5 File Access Reply with quote

Hello, I have a question regarding USB drive redirection on Xenith, connecting to XenDesktop 5.5.

Using a Windows Citrix client on my laptop I can access a locally attached USB pen drive as expected, on a Windows 7 remote desktop, and view and execute files on the disk.

However, when connected from the Xenith, I can see the drive showing in My Computer on the windows 7 desktop, and can access most files, but when I attempt to run an .exe I receive the error "Windows cannot access \\client\filename.exe"

In xen.ini I have added: SessionConfig=ALL MapDisks=yes , to enable drive redirection.

Within the Citrix policies I have allowed:

Auto Connect Client Drives
Client Drive Redirection
Client Removable Drives
Client USB Device Redirection

When using thew Windows client, the USB drive appears on the remote desktop as 'Devices with Removable Storage'. When using the Wyse client, the drive type comes under a category called 'Other'.

Hope someone can help.

Thanks
Back to top
View user's profile Send private message
ConfGen
Jedi Master
Jedi Master


Joined: Apr 20, 2007
Posts: 6269
Location: Germany

PostPosted: Fri Jun 15, 2012 1:55 pm    Post subject: Reply with quote

Use
SessionConfig=all Mapdisks=no VUSB_DISKS=yes

CG
_________________
Try the free Configuration Generator to generate your ini files for WTOS, Linux v6, Linux v7, Ubuntu, Viance or create CE addon packages *** Don't forget to donate via PayPal if you like it *** http://www.technicalhelp.de
Back to top
View user's profile Send private message Visit poster's website
waspy
Newbie
Newbie


Joined: Jun 07, 2012
Posts: 2

PostPosted: Fri Jun 15, 2012 4:15 pm    Post subject: Reply with quote

I configured xen.ini with this setting and it looked promising at first. When inserting the USB drive with a Xendesktop session running, I see the USB icon appear on the notification area with a green tick. But at this moment the session freezes and then get ICA: Connection timed out. A colleague pointed me to the Device=vusb ForceRedirect={Hardware code} setting but this didn't change the behaviour. I've run out of ideas and can't work out what's killing the session.
Back to top
View user's profile Send private message
ConfGen
Jedi Master
Jedi Master


Joined: Apr 20, 2007
Posts: 6269
Location: Germany

PostPosted: Sun Jun 24, 2012 5:38 pm    Post subject: Reply with quote

Is your stick NTFS formatted? This is not supported.

CG
_________________
Try the free Configuration Generator to generate your ini files for WTOS, Linux v6, Linux v7, Ubuntu, Viance or create CE addon packages *** Don't forget to donate via PayPal if you like it *** http://www.technicalhelp.de
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Technicalhelp and Freewysemonkeys Forum Index -> Wyse Xenith All times are GMT + 1 Hour
Page 1 of 1

 

Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001-2008 phpBB Group